Support » Plugin: Internal Links Manager » After activating the plugin, slow homepage

  • Resolved felixlamour

    (@felixlamour)


    Hello,
    the plugin is awesome, however, after activating it, the homepage of the site becomes really slow. Can you please help me to solve this problem?
    Thanks!

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author webraketen

    (@webraketen)

    Hi Felix,

    this could have several issues. Maybe the performance of your server is too weak. I would to suggest you to check following things first:

    – Use Caching-Plugin (e.g. WP Cache, Autoptimize, …)
    – Use a current php version (7.4 or better 8.x)
    – Increase wp_memory on your server (e.g. 1024 M)
    – Increase PHP Time Limit
    – Activate OPcache on your server

    Thread Starter felixlamour

    (@felixlamour)

    The performance of the server is good, I think (private server, 16 gb ram, SSD had). Even if I disable other plugins such as Autoptimize, the performance is very bad when the plugin is activated. PHP version is 8.1, OPcache is enabled. Wp_memory limit is 1024 M. When I activate the plugin the loading time of the home pages goes from 1,29 sec to 10 sec. What am I doing wrong?

    Plugin Author webraketen

    (@webraketen)

    Have you already added any links or is the performance suffering as soon as you activate the plugin – without any links?

    Thread Starter felixlamour

    (@felixlamour)

    I already added a few hundred links. When it is activated, it slows down the site across pages, but in particular the homepage.

    Plugin Author webraketen

    (@webraketen)

    Unfortunately a few hundred links are way to much, as we parse the text for suitable words. I would suggest to reduce the links to a reasonable number.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘After activating the plugin, slow homepage’ is closed to new replies.