Support » Plugin: Add Polylang support for Customizer » after activate the plugin i get PHP Fatal error

  • Resolved foxpc

    (@foxpc)


    Hi,
    i am using last wp and php 7.4
    after i have activate your plugin i get this error
    /plugins/add-polylang-support-for-customizer/includes/class-apsfc.php on line 84

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author richardevcom

    (@richardevcom)

    Hi @foxpc
    Thank you for your submission. I will look into it asap.
    Could you please list plugins and active theme you are using in parallel?
    What version of this plugin have you installed?
    Do you have Polylang installed and activated? If so, what version of Polylang are you using?

    The line 84 has require __DIR__ . '/../../polylang/include/api.php'; this line of code which basically tries to include Polylang API. Please make sure that you have this file in that location: wp-content/plugins/polylang/include/api.php.

    Also please provide full error message (this seems to be cut out). Don’t forget to censor out any sensitive data.

    P.S. I will probably create safer way of API inclusion in upcoming version.

    [EDITED]
    Update: so I changed the line to require WP_PLUGIN_DIR . '/polylang/include/api.php';
    Please update your plugin to lastest version and confirm it is working.
    If not it’s probably due to older Polylang version which means I will have to make Polylang version check and make some conflicting version filters.

    • This reply was modified 7 months, 1 week ago by richardevcom.
    • This reply was modified 7 months, 1 week ago by richardevcom.
    • This reply was modified 7 months, 1 week ago by richardevcom.
    • This reply was modified 7 months, 1 week ago by richardevcom.

    Hello,

    I have the same problem with the latest version of the plugin.
    I use Ploylang Pro so there is not the /polylang/ directory but /polylang-pro/.
    Is it possible to think about the Pro version of Polylang?

    Sincerely,

    Plugin Author richardevcom

    (@richardevcom)

    Hi @spaceshipone thank you for submission.
    I will add a fix for this later this evening.

    Plugin Author richardevcom

    (@richardevcom)

    @spaceshipone uploaded the update. Please update the plugin and check if all works. Thank you for your time posting here. 🙂

    Thread Starter foxpc

    (@foxpc)

    Hi,
    after the last update still the same error
    PHP Fatal error: require(): Failed opening required '/home/public_html/wp-content/plugins/polylang-pro/include/api.php' (include_path='.:/opt/cpanel/ea-php74/root/usr/share/pear') in /home/public_html/wp-content/plugins/add-polylang-support-for-customizer/includes/class-apsfc.php on line 86

    Plugin Author richardevcom

    (@richardevcom)

    Can you please check location of api.php file? It should be in polylang-pro/include/api.php.

    Thread Starter foxpc

    (@foxpc)

    i think the pro dont use api.php because i can’t fint this file in the pro folder but in the free version the file exsist.
    its use rest-api.php instant. the file located in polylang-pro\modules\rest

    Plugin Author richardevcom

    (@richardevcom)

    Can you please check if file is located in /polylang-pro/vendor/wpsyntex/polylang/include/api.php ?

    Thread Starter foxpc

    (@foxpc)

    You are right it’s there.

    Hello,

    It’s all good now. Thank-you for your prompt response.

    Plugin Author richardevcom

    (@richardevcom)

    I’ve updated three locations now, to check for api.php file. It should work.
    @spaceshipone glad to hear that.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘after activate the plugin i get PHP Fatal error’ is closed to new replies.