Support » Plugin: Jetpack by WordPress.com » After 5.2 update, Jetpack disconnected, stats gone after reconnection

  • Resolved jedweb

    (@jedweb)


    I upgraded to 5.2 and then check Site Health. Site Health said that there was a problem with Jetpack and that I should disconnect and reconnect Jetpback. I deactivated Jetpack and then activated it again. After that, my stats are empty.

    Site Health did say that the user who set up Jetpack may not exist anymore. I connected using the only WordPress account I have.

    Did my site ID get changed?

    How can I fix this?

    Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support supernovia

    (@supernovia)

    Hi @jedweb, sounds like we got mixed up between your current site and its previous development installation. We’ve adjusted a setting on this end, but we’ll need you to disconnect and reconnect Jetpack to complete the fix. Want to do that, then let us know if you need more help?

    Hi @supernovia

    Thank you for the response. I have disconnected and reconnected again and all seems to be well, other than the missed stats.

    Unfortunately, the same thing has happened for me on another site: https://jonnys.ca/

    Can you help?

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    With Jetpack, your stats and subscriber information is connected to a unique blog ID. Sometimes, if a site owner was using a development site or a different address when they set up Jetpack, disconnecting may create a new blog ID. When this happens, it may appear that your stats and subscribers were lost.

    That’s what happened on your site; it previously used a different site URL, jonnys.ca/temp-wordpress/

    I have fixed the issue and you should be able to get your stats and subscribers back by reconnecting to WordPress.com from the Jetpack section of your site’s Dashboard.

    Thanks @macmanx. Both of these sites have been running Jetpack fine for years. Why would this happen now?

    Plugin Support supernovia

    (@supernovia)

    @jedweb the previous connection was for jonnys.ca/temp-wordpress/ — when you re-connected, it registered a new site because the address had been updated.

    That temp-wordpress was from a long time ago. It was working fine after that. Just recently this issue cropped up.

    Plugin Contributor James Huff

    (@macmanx)

    Volunteer Moderator

    This is something that can happen, though rarely. In this case, the site was originally registered under the /temp-wordpress/ directory, and apparently it wasn’t ever reconnected until after the site was moved to its main directory, making Jetpack think it was connecting to a new site.

    The good news is, it’s an easy and quick fix, and it will very likely never happen again. 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘After 5.2 update, Jetpack disconnected, stats gone after reconnection’ is closed to new replies.