Support » Fixing WordPress » After 4.4 Upgrade: Unable to Upgrade or Install Themes and Plugins

  • After upgrading successfully to 4.4, am unable to Upgrade or Install Themes and Plugins.

    Every attempt gets an error indicating the directory could not be created, for example:

    An error occurred while updating GoodBye Captcha: Could not create directory. /public_html/wp-content/plugins/goodbye-captcha/

    And of course the .maintenance file is left behind, which I have to manually remove.

    I have tried:

    1. Changing directory perms for wp-content and subs to 775 and 777 (they are at 775 now, were at 755)
    2. Disabling all Plugins
    3. Switching to the 2015 theme

    I have not had any problems with this install prior to the 4.4 upgrade, even as late as last night, before the upgrade, I installed a couple new templates (no they were not activated) successfully.

    Any help is appreciated.

Viewing 15 replies - 1 through 15 (of 36 total)
  • Justin Greer

    (@justingreerbbi)

    Forum Moderator

    @sitesure
    Sorry for the the troubles that you are having? At first glance you have a permission issue on your server.

    Was you running any security plugin during before the upgrade? Some plugins tend to modify file and directory permissions as part of a security feature they offer. have you completely tried to rename the entire plugins directory via FTP?

    An error occurred while updating GoodBye Captcha: Could not create directory. /public_html/wp-content/plugins/goodbye-captcha/

    The error is being cause by PHP not having the correct permissions to handle that directory.

    I have experienced things like this before when I used root user to upload a plugin via FTP and ran my WP install as a standard user. Just as a reference, I want to leave this link here for the suggested file and dir permissions for WP (https://codex.wordpress.org/Changing_File_Permissions).

    When modifying the permissions, ensure to use SSH or FTP with a standard user and not root.

    No, none of my plugins should have modified permissions. The closest thing to a security plugin would be that I have Jetpack’s Protect enabled (remember though, I did try with all plugins, including Jetpack, disabled).

    While I did install a couple of (non-activated themes) via direct FTP, I’m using Dashboard Update to (attempt to) update Plugins and Themes, and the Add New links in WP to try and install.

    I am suffering the same issue on all my WP sites after the upgrade. Permissions are all as they should be and all plug in upgrades worked fine until I installed 4.4 earlier today

    Justin Greer

    (@justingreerbbi)

    Forum Moderator

    @patdundee
    Are you experiencing the same error message?

    An error occurred while updating GoodBye Captcha: Could not create directory. /public_html/wp-content/plugins/goodbye-captcha/

    If not, please start a new topic and give as much detail as possible. There is nothing in WP that modifies file permissions on update which leads me to believe that there is a plugin that is recking havoc here.

    @sitesure
    Are you able to see the error log for you server during your upgrade?

    @justin Greer
    Will do. In the meantime here is an interesting error from the logs 🙂
    Dec 9 18:14:40 W1 pure-ftpd: (me@localhost) [DEBUG] Command [mkd] [/wp-content/plugins/wordpress-seo]
    Dec 9 18:14:40 W1 pure-ftpd: (me@localhost) [ERROR] Can’t create directory: File exists

    That would explain the issues 🙂

    @justin Greer

    That was the issue. If i select update via wp-admin and just before i enter the ftp password i rename the existing folder, it then updates and installs the latest version

    Seems WP has an issue when the folder already exists (Needs looking at in 4.4

    I just tried renaming the folder for the plugin, at the same stage Justin mentioned, and while it appears to succeed, the upgrade failed because WP notices the original plugin no longer exists.

    Also, it isn’t just a file already exits error, or installs would succeed.

    The only errors in the log are from the last experiment, renaming the directory prior to the install. There are no errors recorded from just installing or updating.

    Bill

    Justin Greer

    (@justingreerbbi)

    Forum Moderator

    @sitesure
    So if you rename the plugin directory manually before starting the upgrade, you still get an error?

    – Rename the plugin directory
    – Visit your plugins page (all plugins should be gone)
    – Change theme to latest default theme
    – Attempt upgrade
    – Reactivate desired theme
    – Rename the plugins directory back to plugins

    Please ensure you have a backup before doing anything though

    No not quite
    Go to the updates
    Select the plug in
    select update
    before you put in your ftp password go to standard ftp and rename existing folder
    go back to wp admin and enter ftp and then update.
    Basically it is installing the new version as a fresh install so just need to remember any purchase / registration code.
    that way works fine.
    Only issue if is there is an existing folder with the same name

    I have installed all of yoast updates over the past couple of weeks from 3.0 to 3.06 in the previous WP 4.3 version without nay issues.
    Due to the issues with that current version of the plug in I have always rolled back

    Each time it has always updated in 4.3 without any issues

    Since 4.4 install earlier I can no longer update any plugins including yoast due to the error shown in the sys logs previously

    Running Linux Ubuntu Server 14.04
    Running Pure-FTP
    everything else on the server or other servers that have not been updated to 4.4 are all still working fine 🙂

    Justin Greer

    (@justingreerbbi)

    Forum Moderator

    @patdundee
    Please only post in your topic.

    Thanks

    When I rename the directory before entering the FTP password in the console, I get different errors, WP doesn’t even get to the point of trying to create a directory:

    [Wed Dec 09 13:47:06 2015] [error] [client 65.204.185.250] PHP Warning:  fclose() expects parameter 1 to be resource, boolean given in /home/catrina/public_html/wp-includes/functions.php on line 4464, referer: http://catrinacosta.com/wp-admin/update.php?action=update-selected&plugins=goodbye-captcha%2Fgoodbye-captcha.php&_wpnonce=9444f6dda3
    [Wed Dec 09 13:47:06 2015] [error] [client 65.204.185.250] PHP Warning:  fread() expects parameter 1 to be resource, boolean given in /home/catrina/public_html/wp-includes/functions.php on line 4461, referer: http://catrinacosta.com/wp-admin/update.php?action=update-selected&plugins=goodbye-captcha%2Fgoodbye-captcha.php&_wpnonce=9444f6dda3
    [Wed Dec 09 13:47:06 2015] [error] [client 65.204.185.250] PHP Warning:  fopen(/home/catrina/public_html/wp-content/plugins/goodbye-captcha/goodbye-captcha.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: No such file or directory in /home/catrina/public_html/wp-includes/functions.php on line 4458

    As expected, since WP expects the plugin to exist.

    (BTW, this site is NSFW, feel free to visit, just wanted anyone to be aware)

    I’m seeing the same thing, in my case trying to update the All In One WP Security and MailChimp for WordPress plugins and the Twenty Ten and Twenty Thirteen themes. The error looks like the WordPress Updates code is trying to create a directory when that directory already exists.

    I rolled back to the earlier version and the updates all worked fine again 🙂

    I’m seeing the same error. Its put our website both back end and front end into maintenance mode. It happened when I tried to do a TinyMCE Advanced update and then again today when I tried to do a Wordfence Security update.
    I have managed to get it out of maintenance mode but unsure how the updates are going to be updated since these errors have only occurred since the 4.4 WordPress update
    Regards Karyn

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘After 4.4 Upgrade: Unable to Upgrade or Install Themes and Plugins’ is closed to new replies.