Support » Networking WordPress » After 3.0 upgrade, cannot enable multi-site

  • Performed the upgrade without problems, but one of the reasons to do the upgrade was to enable multi-site support.

    I’ve performed the initial edit of /wp-config.php as directed in http://codex.wordpress.org/Create_A_Network … Step 3, but the
    Network Tool isn’t popping in the Tools menu.

    Everything else seems to be working, but because the Network tools aren’t available, we can’t go multi-site.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    quite possible if you copy/pasted in Windows, you have an issue with the quotes around the define. It needs ‘ this kind. Not fancy ones.

    Did you find a solution?

    I have the same issue. The Network tools option never becomes visible.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    It’s either the quotes or it’s in the wrong place in the file.

    I’ve never seen the Network Tool on any of the sites I’ve upgraded – either standalone or WPMU – even after doing all the right stuff to supposedly show it. But then I’ve also only ever used the auto upgrade and that messed up every site I tried it on.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    You won’t need the Network menu if you upgraded from MU. you are already running a network, so why would you ever go enable it?

    I’ve enabled the network on single WP installs on a few different hosts now. It only fails to show under two circumstance:

    – the define is in the wrong spot in the config file (either above or below the comments that say “don’t edit above/below this line”
    – the define has curly or smart quotes around it.

    That’s it.

    That’s what I thought – but I’m not even getting it on new clean first-time-ever standalone installs

    The codex, readme, and other documentation needs clarified relating to
    the actual define line to use too – MULTISITE or MULTISITE_INSTALL and so on – it’s a bit foggy, even for a WP and WPMU old-hand like me.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    the codex says in step 3
    http://codex.wordpress.org/Create_A_Network#Step_3:_Allow_Multisite

    To enable the Network menu item, you must first define multisite in the wp-config.php file.

    Open up wp-config.php and add this line above where it says /* That’s all, stop editing! Happy blogging. */:

    define(‘WP_ALLOW_MULTISITE’, true);

    I ma not sure how to make it any more clear than that.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘After 3.0 upgrade, cannot enable multi-site’ is closed to new replies.