Support » Plugin: WooCommerce » After 3.5.0 update Several Tables Are Missing

  • Resolved Matt

    (@mporraro)


    I updated Woocommerce from 3.4.7 to 3.5.0 on Oct 23rd. I ran the database updater as per update instructions. I checked system status and there were several tables missing. I replaced my site with a backup and am using Woocommerce 3.4.7 without any trouble.

    I also have disabled all plugins, and tried to updating. The same problem occurs.

    General enviroment conditions:
    I have a multisite, WordPress 4.9.8, Server Apache, PHP 7.2.6, Mem limit 1G, WooCom database version 3.4.7, Total Database Size 169.89MB, Database Data Size 140.20MB, Database Index Size 29.69MB, cURL version: 7.54.0, OpenSSL/1.0.2k, theme is Athena Pro.

    Can someone help with this issue?

    Regards

    Matt

Viewing 15 replies - 1 through 15 (of 20 total)
  • neoseeyou

    (@neoseeyou)

    Hello Matt

    Same problem for me as well. False positive?

    Edit: order process is still working by the way

    kaboemnld

    (@kaboemnld)

    Hello,

    It don’t save the product variations, for new products

    Zlato

    (@zlato)

    same problem, Several Tables Are Missing.
    Come on, guys or you can test before the update date. The previous version gave us an uninterrupted weekend and costs due to user roles. Now, that’s it.
    Apparently, the mandatory equipment besides wooocmerce plugin is also WP Rollback plugin.

    with all respect

    neoseeyou

    (@neoseeyou)

    any news about that?

    Matt

    (@mporraro)

    Neo,

    No news yet.

    I have tried all the standard update techniques. Changed the theme to one recommended for woo, turned off all plugins and tried to update. All attempts have the same failure. I loose all Woo tables except 2 tables.

    neoseeyou

    (@neoseeyou)

    Matt, in my case, all tables are still present on my database. It just writing on system status that some tables are missing but all informations are in place.

    Matt

    (@mporraro)

    Neo, I have not checked my database tables to see if they exist. I only see the “tables do not exist” notices in the system status. will check database to see if they exist.
    thanks

    Matt

    (@mporraro)

    Neo, I just updated on my test site, and yes, the tables do “actually” exist in the database and show “Table does not exist” in the system status report. Not sure what the next step is. Is the issue just a problem with the reporting function or is the issue a more serious problem with the database and other functions?

    Your thoughts?

    neoseeyou

    (@neoseeyou)

    don’t know but i hope they can fix it with a new release soon

    Matt

    (@mporraro)

    Neo,

    i believe that the issue may be in the database updater. The updater was taking a long time to finish the update. I clicked the link “taking too long update now” and that seemed to complete the process. However, the issue still persists. My database is about 150 Mb.

    johnk12

    (@johnk12)

    Seems to be multisite only, and the tables are still there, they are just reported as not.

    Matt

    (@mporraro)

    John,

    Multisite may be part of the issue. I updated one of my sites that is single site and woo updated correctly. The site that I am having issues with is multisite. Tables exist in database but not in system reports.

    neoseeyou

    (@neoseeyou)

    Exactly

    Matt

    (@mporraro)

    John,

    The problem is multisite. I turned off multisite (set to “false” in wp-config file) and was able to update correctly and the system report did not have any errors. I then reset the wp-config file to “true” and the system report showed “tables do not exist”.

    Hope this helps. Your Thoughts?

    What is next?

    johnk12

    (@johnk12)

    My thoughts? Should test woo updates on multisite test site first next time. 😉

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘After 3.5.0 update Several Tables Are Missing’ is closed to new replies.