Support » Installing WordPress » After 2.5 upgrade my “Pages” give 404 error

  • Resolved Giofilo

    (@giofilo)


    Hi,

    After 2.5 upgrade all properly works (also the permalinks to the posts).

    All works…except the Pages! They give a 404 error!

    I have updated the permalinks more times, but the Pages don’t work yet.
    If I create a new Page, it doesn’t work too!

    Help me, please!

    Thanks,
    Giovanni

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator kmessinger

    (@kmessinger)

    Change the permalinks to default. Save.
    Change the permalinks to what you want. Save and note the changes that you need to make to the htaccess file.

    Hi kmessinger!

    When I change the permalinks to default, the Pages work.
    When I change the permalinks to what I want, they don’t!

    Please, can you tell me what I have to change in htaccess file?

    Thank you very much!
    Giovanni

    At the bottom of the permalink page is the correct info that needs to be in the .htaccess file. Either let WordPress update it, if the file is writable or make a file yourself by copying and pasting the new code. Save it in Unix format. Might have to make it htaccess.txt then change file name once uploaded.

    Hi mog

    My WordPress is able to create and update the .htaccess, therefore it doesn’t show anything at the bottom of the permalink page. My .htaccess file has this content:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I don’t understand: if it is a problem of permalinks, also the post’s permalinks (not only the page’s permalinks) don’t have to work. Instead they work!

    Thanks!

    Then please post your permalinks setup. It might be not well-defined so that wordpress can not find your posts and pages.

    Hi hakre,

    My permalinks setup is: /%year%/%monthnum%/%day%/%postname%/

    Thanks!

    That shouldn’t be the cause why you run into problems. I tested it against version 2.6 Bleeding. Infact it is a Common Setting called Day and name.

    And it is still the problem that your posts work but not your pages? Maybe you have a page that is named the same like a category?

    Moderator kmessinger

    (@kmessinger)

    AFAIK, you do not need </ifmodule> in your .htaccess. WordPress did not put that in mine.

    kmessinger, which version are you using?

    Moderator kmessinger

    (@kmessinger)

    I am using 2.5 of course :^)

    Moderator kmessinger

    (@kmessinger)

    I needed to scoll down to see </IfModule> so I will add that.

    Thank you!

    Maybe you have a page that is named the same like a category?

    No, I don’t.

    I don’t know what to do: I can’t believe that I can’t use pages wp 2.5!

    Resolved: I have had to reinstall 3 times WP 2.5 and now all the permalinks seem to work!

    I don’t know what was the problem.

    Thank to all for the help!

    Okay, maybe a forced db upgrade might have helped as well. See

    1. Codex: Forcing a Database Upgrade
    2. Re run the upgrade process
Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘After 2.5 upgrade my “Pages” give 404 error’ is closed to new replies.