WordPress.org

Support

Support » How-To and Troubleshooting » Afraid of Upgrading to 2.9 due to Customization Loss

Afraid of Upgrading to 2.9 due to Customization Loss

  • When I upgraded from 2.8.4 to 2.8.5, many of my customizations were lost and I had to laboriously re-do them. So now I’m reluctant to upgrade, because I know I’ll have to go through the process again.

    These are the files that I’ve made alterations to which will most likely be lost once I upgrade:

    • wp-login.php
    • login.css
    • common.php
    • comment-template.php
    • wp-comments-post.php
    • comment.php
    • wp-install.css
    • default-widgets.php

    Question: Is there any way to upgrade without upgrading these particular files? Or to upgrade them such that my customizations will be retained? Or to selectively upgrade only those files which contain “important” upgrades?

    One way, of course, would be for me to simply copy these files as they are now, then upgrade, and then delete the 2.9 version of these particular files and replace them with my old ones. But then I’m not sure if the old ones will be compatible with 2.9, as 2.9 may contain some general re-structuring and may have consolidated or gotten rid of certain files altogether, and hence “mixing” versions may not work.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Here is what I do:

    1. download new version of WordPress
    2. download the version I’m using
    3. unzip each
    4. from new version download, load first file (wp-login.php, in your case) into NotePad++
    5. load same file from old version
    6. from the menu bar, Plugsin-Compare-Compare
    7. if files match, I can safely use my old modified file with the new version
    8. if files don’t match, I re-do my modifications to the new version’s file
    9. repeat, from step 4, for each file

    My website has heavily been customized and now i’m afraid i’ve lost everything after upgrading to 2.9.

    I’m so furious and annoyed, spent so much money having the website customized throughout and now i cant access it.

    http://www.visitlocal.co.uk

    Total disappointment!

    Thank god i backed up the files before hitting upgrade 😀

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Afraid of Upgrading to 2.9 due to Customization Loss’ is closed to new replies.
Skip to toolbar