Support » Plugin: Gutenberg Blocks - PublishPress Blocks Gutenberg Editor Plugin » Advanced Tabs does not display content in the front

  • Resolved artfish1

    (@artfish1)


    In the admin panel, the plugin works fine: the contents of the tabs will be displayed correctly. However, in the front part of the site, where there is more than one tab, the content of the tabs is not displayed and the tabs themselves are gray (as if inactive). In addition, on every page with such a problem, the console displays an error:

    Uncaught TypeError: Cannot read properties of undefined (reading ‘apply’) (jquery-migrate.min.js?ver=3.3.2)

    I am using WordPress 5.8
    I tried to disable all plugins: it does not help.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter artfish1

    (@artfish1)

    With the update to WordPress 5.5, a migration tool known as jquery-migrate was no longer enabled by default. This may lead to lacking functionality or unexpected behavior in some themes or plugins that run older code.

    This plugin serves as a temporary solution, enabling the migration script for your site to give your plugin and theme authors some more time to update, and test, their code.

    We ask the authors of the Gutenberg Blocks plugin – PublishPress Blocks to fix the migration issue as soon as possible. Thanks.

    Plugin Author htmgarcia

    (@htmgarcia)

    Hi @artfish1,
    I see a couple of tabs below “Le projet” which works fine in my end. Please let me know if I’m missing any detail.

    Regards

    • This reply was modified 1 month, 2 weeks ago by htmgarcia.
    Thread Starter artfish1

    (@artfish1)

    @htmgarcia These tabs work fine thanks to a dedicated plugin: jQuery Migrate Helper (https://wordpress.org/plugins/enable-jquery-migrate-helper/). As written in the description, this is a temporary solution. And the permanent solution should be yours, as the authors of the PublishPress Blocks plugin, to update it to remove the dependency on jquery-migrate. I’ll disable this temporary plugin (jQuery Migrate Helper) for the rest of tomorrow so you can see the problem in action at the same link (http://butafor.info/blog/portfolio/discotheque-pulse/).

    Plugin Author htmgarcia

    (@htmgarcia)

    Thanks for sharing more details!

    Unfortunately I’m not able to reproduce the issue in my end. In our demo, Adv. Tabs works fine: https://demo.publishpress.com/advanced-tabs/ – Please note there is a possibility the theme in use or other plugins may be involved.

    Please test for a minute under other theme, and/or deactivate other plugins (e.g. Simply Gallery) to see if the issue is gone. This may confirm my guess.

    Looking forward to help you

    • This reply was modified 1 month, 2 weeks ago by htmgarcia.
    Thread Starter artfish1

    (@artfish1)

    @htmgarcia Yes, it looks like you were right. I tried to install theme “Twenty twenty one” and your plugin works fine there. It means it’s all about my current theme, the problem of which is displayed on the plugin. Thanks for the support. The question is closed.

    Thread Starter artfish1

    (@artfish1)

    Perhaps someone will need information on how I solved the problem with the theme, since this theme was made by me.

    Firstly, I removed the jQuery connection from the functions.php file, since WordPress itself connects it.

    Secondly, in all my js files, I wrapped the code in a function like this:
    jQuery (function ($) {
    // Your code here
    });

    Plugin Author htmgarcia

    (@htmgarcia)

    I’m glad you figured out, @artfish1 ! Thanks for sharing the solution so other users may benefit from your experience.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.