Support » Plugin: TinyMCE Advanced » Advanced Options Reset to Default Values

  • Resolved Eusebiu Oprinoiu

    (@eusebiuoprinoiu)


    Hello, Andrew!

    After the last update, the Advanced Options of TinyMCE Advanced are reset to their default values. This happened in the past for every update after the Classic Paragraph was introduced.
    Can you, please, investigate and prioritize a fix for this issue? It’s not OK to reconfigure the plugin after every update…

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    Hi Eusebiu,

    Yes, it’s definitely not OK to reset options after an update.

    There is a fairly big chunk of code dealing with setting defaults for the new options, here: https://plugins.trac.wordpress.org/browser/tinymce-advanced/tags/5.2/tinymce-advanced.php#L396. It works in a pretty standard way for WP: saves a version number in a separate option in the DB, then after an update checks it and adds default values for the difference in the settings between the current plugin version and the new version.

    I’ve actually tested this quite a bit, and it seems to work properly here. Not sure why advanced options were reset… In 5.2 there are several new advanced options, mostly for tables. They should have been set, but none of the previous options should have changed.

    Could you tell me a bit more: which options were set before the update and which were set/reset.

    Hello, Andrew!

    I had everything under Advanced Options disabled.
    I only customized the toolbar for the Classic block and the Classic Editor.
    The other options weren’t affected by the update. (or at least I haven’t noticed anything out of place)

    Settings before the update: https://i.imgur.com/w5MjmiE.png
    Settings after the update: https://i.imgur.com/95o2Tv3.png

    Plugin Author Andrew Ozz

    (@azaozz)

    Thanks for the screenshots! 🙂

    Yes, the top two options: “Add Classic Paragraph…” and “Make default block…” shouldn’t have been re-enabled. Looking into it.

    The new options, all advanced settings for tables and the separate “no-autop” for the block editor were set to their defaults properly it seems.

    You’re welcome!
    And thank you for investigating the issue so fast.

    Plugin Author Andrew Ozz

    (@azaozz)

    Hm, think I found the problem. Will test a bit more and add a fix. Will be in the next version.

    Thanks for reporting this! 🙂

    Thank you very much, Andrew!
    I appreciate you took to time to investigate and fix this!

    Plugin Author Andrew Ozz

    (@azaozz)

    Should be fixed in the latest version.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Advanced Options Reset to Default Values’ is closed to new replies.