Support » Fixing WordPress » Advanced Options in Page Management Missing after upgrade

  • Please help–since upgrading I have no way of managing my page orders, parents, and sub pages, among all the other advanced page management options.

    I’ve been up all night searching google, codex, and these forums, but can’t seem to find anyone else who had the same problem i’m having, so I’ve finally decided to post my first inquiry here.

    I was originally using 2.3.3 for the longest (i think that’s what it was)for Thailand-USA site and finally decided to go through with the upgrade to 2.5. Did it all by the instructions, backing everything up, setting permissions, etc. and it all seemed to work just fine, that is until I get to to the write/edit pages panel of 2.5, where none of the Advanced options are available like they used to be in the older version (i.e. page slug, page template, and most importantly for me, page parent and order)

    The only extra option on my write and edit pages panel, at the bottom is for the All in One SEO plugin options. On the right is just the save, delete, and publish options. No advanced options to be found.

    I know for a fact that that 2.5 should have all the advanced goodies, as I’m using it on another blog on the same server that has no problems. So it seems something must have gone wrong with the upgrade. I’m so reluctant to go with a restore and retry method as I’ve already spent ages getting it upgraded as is on top of all the hours i spent trying to integrate it with a bbpress forum in a sub directory. So if I’m lucky, perhaps there is a quick fix.

    Please, someone point me in the right direction of what the problem is. Surely I can’t be the only one who has had this problem. Even the pagemash plugin won’t let me change around my parents/subpages like it should, so somehow my page ids are locked and inaccessible for some reason…

    Any guesses, expertise, or leads will be greatly appreciated.

    Much thanks in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Update:

    So I went ahead and backuped everything, deleted everything, and reinstalled, emptying the database out as to recover it via sql dump, and was amazed that my options returned, until I restored the sql dump and i was back at phase one.

    Deactivated all the plugins to see if it had any affect and it absolutely did, as the options were back with the plugins, so i had to activate each one refreshing my admin page to see which plugin was causing it and it turned out that it was the wordpress email notification version 2.3.1. Ah well, had to deactivate it and will tryin downloading and activating it again later to see if it was just a bug in my files or if the plugin is actually not getting along with wordpress 2.5.

    Relieved that it was only the plugin that’s not super essential for me at the moment. If anyone else has a clue why this plugin caused such an error and how to fix it or at least can suggest another email notifier plugin that doesn’t have the same bug, please do so.

    Cheers for now,

    Hi Siamerican

    I have the exact same problem, and I also had the All in one SEO pack, installed.

    It was also the SEO pack I could see as the last thing on the post edit page, so I tried removing the All in one SEO pack, and the settings came back – but now it gets peculiar – only for a while!

    2 days later, without the All in one SEO pack I couldn’t see the rest of the advanced settings again, so I gues it couln’t be the SEO pack.

    Then I tried all my other plugins, one by one, and when toggeling the Vipers Vide Quicktag off, my advanced settings came back, when activating Vipers again, my settings dissapeared. I’ve tried that 5 time in a row – everytime the same reaction, so I thought I had found the problem, and deactivated the Vipers plugin.

    Now, without Vipers, the problem is there AGAIN!

    The Advanced settings are gone for some few post. Most often the ones that I’m editing at the time. Also the comments turns off automatic for that peticular post, and I can’t set it on again, because the settings are missing 🙂

    Now I have deactivated 2 plugins, and after a while the problem comes again, so I’m not sure it’s any of the plugins. I really don’t have a clue, and I’m also ready for almost anything, just to make it dissapear.

    No one in the danish forum has the problem, and I’m a bit surprised that I’ve only found you, almost on the other side of the earth, with the same problem.

    But I actually don’t believe that it was your specific plugin that caused the problem, as I could remove the fault also by deactivating some plugins one by on.

    But the problems always after a while, and why should Email Notification, My SEO pack, and Vipers Quicktags cause the same problem?

    I also believed that I had found the error, but I always returns, so maybe it has to do with the plugins, but I don’t think it’s a specific plugin. It’s more likely somthing with the 2.5 and now 2.6 and the plugin section.

    Best regards Peter, Copenhagen

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Advanced Options in Page Management Missing after upgrade’ is closed to new replies.