• Resolved yatesa01

    (@yatesa01)


    We use four icons that we use on our homepage. They used to display correctly, but after updating to WordPress 5.5, they just show the icon name in an italic font. I’ve deactivated the cache and have checked on multiple devices and browsers, all of which show the same thing.

    The odd thing is that the icons show just fine when I go into the page editor.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author htmgarcia

    (@htmgarcia)

    Hi @yatesa01,
    please update to Advanced Gutenberg 2.4.1. The version we just released today.

    Thread Starter yatesa01

    (@yatesa01)

    I already did. It is currently running 2.4.1, but it hasn’t changed the behavior. A little bit more digging around shows that when I put an Advanced Icon block on a post, it does display correctly. Check out https://ecctconvention.org/2020/08/we-are-the-body-of-christ-digital-mosaic/

    Plugin Author htmgarcia

    (@htmgarcia)

    Please clear WordPress and browser cache, in that order.

    Thread Starter yatesa01

    (@yatesa01)

    I did that, and I’ve deactivated our wordpress cache for the time being. Still not showing up on the home page.

    Plugin Author htmgarcia

    (@htmgarcia)

    In your homepage the file material-icons.min.css isn’t loading. I suspect that’s causing the issue.

    Your homepage is a regular page?

    Thread Starter yatesa01

    (@yatesa01)

    Yes, it is just a regular static page. I’m using the stock Twenty Twenty theme.

    Plugin Author htmgarcia

    (@htmgarcia)

    Is possible to have the HTML of that page? You would need to switch to code editor, copy-paste the code into a file.html and send me that attachment to valentin [at] publishpress.com

    Don’t forget to include the link of this support topic in the message as reference.

    Thread Starter yatesa01

    (@yatesa01)

    Just sent it. Also, I’ve continued to poke around and it seems that the problem is related to having the blocks in columns. When I put two columns with icons in on https://ecctconvention.org/2020/08/we-are-the-body-of-christ-digital-mosaic/ they don’t show up, just like on the home page. However, if I place one icon on the page that isn’t in a column, then the icons all show up, except that the icons in the columns are all small, even though they are set to the same size.

    To add to yatesa01’s last point, I believe this issue might be caused by the Columns Manager block. All of my Advanced Button blocks inside a Columns Manager Block are set to a default setting on the live site (but look stylized in the Dashboard). However, Advanced Buttons anywhere else seem to retain their formatting.

    This seems to be an issue for me since updating this plugin today.

    Advanced Images Blocks seem to also have issues while in Columns Manager Blocks.

    Plugin Author htmgarcia

    (@htmgarcia)

    Hi @dugano and @yatesa01,
    that’s correct. When blocks are inside groups or columns, you may see issues related to missing CSS mainly.

    We’re already working on it.

    Plugin Author htmgarcia

    (@htmgarcia)

    This seems to be an issue for me since updating this plugin today.

    @dugano I can confirm today’s update is not related. If you test AG in WordPress 5.4.2, it will work fine. However the issue will come up in a WordPress 5.5 site.

    I can confirm that the WordPress 5.5 Update broke the icon support. With “Advanced Gutenberg” 2.4.0 and 2.4.1 it doesn’t show the icons.

    I test with the FireFox-Development tools and insert the <link>-Tag for the “material-icons.min.css”. Then it shows the icons, but not the alignment. I have multiple icons some left binded and some centered. In the backend it shows correct only in the frontend all icons are left binded.

    I inspect the DOM and wonder cause only two links to the plugin directory “advanced-gutenberg” exists.

    <link rel='stylesheet' id='advgb_blocks_styles_min-css' href='http://am.visionenmaler.de/wp-content/plugins/advanced-gutenberg/assets/css/blocks_styles/blocks.min.css?ver=5.5' type='text/css' media='all' />

    and

    <script type='text/javascript' src='http://am.visionenmaler.de/wp-content/plugins/advanced-gutenberg/assets/blocks/advtabs/frontend.js?ver=2.4.1' id='advgb_tabs_js-js'></script>

    but there is no link to

    http://am.visionenmaler.de/wp-content/plugins/advanced-gutenberg/assets/blocks/frontend.js?ver=2.4.1

    Could it be, that the frontend.js is linked to the wrong directory?

    Regards

    Plugin Author htmgarcia

    (@htmgarcia)

    We just made a new release to fix the styling issues that affected a few blocks inside columns and groups. Please update.

    @htmgarcia Since 2.4.2 everything works fine. Thank you very much for the quick changes.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Advanced Icon not displaying’ is closed to new replies.