Support » Plugin: Caldera Forms - More Than Contact Forms » Advanced file uploader not working

  • Resolved isdoo



    The basic file uploader appears to work for one file. Despite ticking the multiple box, I can only select one.

    The advanced one, will select multiple files, but when submitting the form it fails. No error message, the submit box is then disabled. Advanced also fails if multiple is off and just one file. Tried with attach to mailer on/off, add to media library on/off

    Tested on Chrome, latest version.


Viewing 9 replies - 1 through 9 (of 9 total)
  • You probably already know this. But have you checked your upload limit size?

    Hi there,
    experiencing exactly the same problem: both file uploaders not working, on submit seem to hang without any error message. Tried to disable/enable the same settings as above.
    Not a file size problem, I try to upload txt files of around 7 kb. Same goes for .doc, .docx and .pdf: small files, no upload. WP does accept these file types.

    Thread Starter isdoo


    You probably already know this. But have you checked your upload limit size?

    Yes – not applicable.

    Plugin Contributor christiechirinos


    Hi all,

    It’s hard for me to give actionable advice without looking at your form plugin settings, but you could rule out a handful of things.

    1. Like pf4 said, upload limit size. You need to check both with your WP files and your host. This could be causing your file uploads to fail.

    2. Have you minded your file permissions?

    3. Are the file types you are trying to upload accepted? Sometimes it’s beneficial to specify the types of files accepted within Caldera Forms, see

    4. Finally, it is a known bug that file uploader fields aren’t uploading properly if you are using our Verify Email addon:

    Thread Starter isdoo



    Many thanks for the reply.

    Single files are fine with the basic uploader, but that also fails with multiple ones. So I know it is not one of permissions.

    I tried both with and without the size limits and no joy.

    The only verification that I am using is to confirm that the T&C have been read.

    Incidentally using contact 7 form works fine with multiple attachments, but would rather switch to your service.

    Reached a brick wall at the moment 🙁

    Hi there,

    brick wall for me as well. As for Christie’s items:
    1. Uploaded files were in the range of 5 – 7 kB… if that is a problem, I think 99% of users is with me.
    2. Checked file permissions, no probs there. I didn’t change the uploads folder. I experience the problem on 3 different sites, 2 of them did not have their permissions changed, did work before (tested!) but now it doesn’t. Third site is still under development, didn’t work from the start.
    3. Tried the upload without specifying the file types, and with specifying -> need .txt / .doc / .docx / .pdf. None of them work.
    4. No addons installed.

    I see this thread is marked as resolved, but I am having the same issue and don’t really see a resolution above.
    My issues:
    1 – The file uploader won’t allow selection of multiple files, even when this feature is ticked
    2 – The advanced uploader allows multiple files but does not attach the files to the new post type I am creating, nor does it map them to the correct field.

    I would prefer to use the basic file uploader at this stage as at least I know that the file is attached to the post and it is assigned to the correct custom field.

    Did anyone find a solution?

    Thread Starter isdoo


    I didn’t set it to being resolved. The author must have done, which is sad 🙁

    certainly not resolved.

    Hi there,
    for me the problem did resolve. If I recall correctly, it was right after the latest (June 27) update… So regardless of it being strange indeed that a non-solved topic is being closed, for me it worked out.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Advanced file uploader not working’ is closed to new replies.