Support » Plugin: Advanced Excerpt » Advanced-Excerpt causing excerpts only, to show on all posts.

  • With Advanced-Excerpt activated I am getting two problems on my posts.

    One is just a message under a google advert, which says: (adsbygoogle = window.adsbygoogle || []).push({});

    Lookin at the page source code I see this:

    VM1705 adsbygoogle.js:54 Uncaught M {message: “adsbygoogle.push() error: No slot size for availableWidth=0”, name: “TagError”, pbr: true, stack: “TagError: adsbygoogle.push() error: No slot size f…esyndication.com/pagead/js/adsbygoogle.js:62:357)”}

    The other is more serious, as it only show the first 50 words in my full post. This 50 words is the limit I have set for excerpts.

    After the 50 words it shows the “… Read the rest” message, which, redirects it back to itself with the same excerpt only showing.

    This appears to have only happened from yesterday, and I have no idea what might have changed to cause it.

    I deactivated the ‘adsbygoogle’, and the first error went away, as there was no advert, but the post is still limited to 50 words. Reactivating the ‘adsbygoogle’ brought the error message back again.

    I am keeping the Advanced-Excerpt deactivated, until I can find a solution to get the full post back again.

    Both issues go away with Advanced-Excerpt deactivated. But I am not 100% sure it is just down to Advanced-Excerpt. Or other sites would have the same issue..

    It is happening on abcdiamond.com.au, but, I have only just worked out, only on posts created yesterday..

    Any ideas ?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi @abcdiamond

    adsbygoogle

    Some plugin (or the theme) is adding that JS code for Google ads.

    Our plugins strips all the HTML code so it also strips the script tag which makes that code show up as plain text.

    In the plugin settings, at the end, you’ll see the option “Strip Tags”, set that to “Don’t remove any tags”.

    Or alternatively you can keep it to remove tags but in the checkboxes below check “script”, so it doesn’t strip that one.

    If it’s not shown in the list, there’s a select box at the bottom, find “script” in there and click “Add Tag” button.

    Word limit

    Does that happen on a regular single post page where the full content is supposed to be shown?

    • This reply was modified 4 months, 1 week ago by WPKube.

    I selected “Don’t remove any tags” and that fixed it.

    It was happening on a regular single post page where the full content was supposed to be shown.

    When I switch back to “Remove all tags except the following” it trims the regular single post to just 50 words, and messes up the google advert.

    However, it does not seem to happen on ALL posts. That is very puzzling, as I can’t see anything different between the posts.

    Plugin Author WPKube

    (@wpkube)

    Hi @abcdiamond

    It shouldn’t be doing any modifications on a single post page, there is code in there that checks for that specifically and if it’s on a single post page it doesn’t do any filtering.

    It’s a native WordPress function (to check if it’s single post page), so shouldn’t be any issues with that.

    Can you send over an example of a post where things work fine and an example of a post where the issue happens, it might give me some idea as to what’s going on.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.