Support » Plugin: ACF Options For Polylang » Advanced Custom Fields should be on version 5.6.0 or above

  • Cannot upgrade ACF Pro from 5.9.9 to 5.10 (or 5.10.1) because this plugin complains with
    “Advanced Custom Fields should be on version 5.6.0 or above”
    In the world of versioning 5.10 is higher than 5.9
    This should be an easy fix, but strangely has not been sorted. Odd considering ACF is a requirement.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The error is coming from the file /classes/requirements.php on line 21.
    The If-Statement compares a String to an Integer which causes the misinterpretation.
    I was able to reactivate the Plugin by changing the corresponding line as followed.

    if ( '5.6.0' > acf()->version ) {

    to

    if ( (int)'5.6.0' > acf()->version ) {

    It’s just a temporary solution as most devs won’t handle plugins in their repository and therefor changes have to be remade after every new deployment.

    • This reply was modified 10 months, 1 week ago by cmbsmr. Reason: Spelling mistakes and formating
    • This reply was modified 10 months, 1 week ago by cmbsmr.
    Thread Starter sirjeff

    (@dwaynepivac)

    Thanks @cmbsmr – yeah I can’t touch the code, like you said, next deployment the code would update anyways 🙂
    Hoping the developers will apply this ifx.

    A. Albrecht

    (@alexander-albrecht)

    same problem here on a lot of pages. should be resolved very soon. a bit annoying 🙁

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Advanced Custom Fields should be on version 5.6.0 or above’ is closed to new replies.