Support » Plugin: WP Super Cache » advanced-cache.php$wp_cache_file does not exist !

  • Hello,

    I recently installed WP Super Cache on WordPress 3.6.1. I am stuck with a message saying that I must open “advanced-cache.php$wp_cache_file” but this file is nowhere to be found. Instead, I found “advanced-cache.php”. I am assuming this the file I must take in account. So then I am asked to replace “CACHEHOME” text with another text but I can’t find it ! I only find “WPCACHEHOME” instead …
    I am really lost with the installation of this plugin, can someone help me please ?
    It would be much appreciated because I reaaly need it.
    Thank you in advance,

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the exact same message when trying to activate 1.4 or 1.3.2 on WordPress 3.7. My wp-content is writable but still get the message that advanced-cache.php cannot be created. And despite this being the fourth WordPress site I install WP Super Cache into, it does not seem to work. Perhaps I should downgrade from WP 3.7?

    Not sure it’s going to solve your problem because I have this problem too with 1.4 on WP 3.6.1 …

    Hm, that’s true.

    I also tried to define the WPCACHEHOME in the wp-config file (as suggested in this thread: ), but that also didn’t work for me.

    Thank you for the link, I will try it asap and will keep you informed.

    I solved it by creating a file called ‘advanced-cache.txt’ in the wp-content directory (I could not upload a php file directly).

    Then I renamed the file to ‘advanced-cache.php’ and refreshed the WP Super Cache settings page in the WordPress Admin. Then it worked!

    I still don’t understand why this error occurred, since the first thing that WP Super Cache said was “Warning! Wp-content is writable!”. Ironically, ten seconds before that the error message said that wp-content was not writeable.

    Finally I uninstalled Super Cache and installed W3 Total Cache instead. It works like a charme.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘advanced-cache.php$wp_cache_file does not exist !’ is closed to new replies.