Support » Plugin: Advanced AJAX Product Filters » Advanced AJAX Product Filters and WP-rocket

  • Resolved mladja11

    (@mladja11)


    Hi,

    I am trying to speed up my website, and obviously, there are some files needed to be excluded. I am using WP Rocket. So, what should I do?

    It stops filters from working just with enabling the plugin.

    Could you help me with this?

    BR,
    M.

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author RazyRx

    (@razyrx)

    Hello,

    Do you have latest version of plugin?

    Try to enable option “Fix for site with AJAX” in plugin settings -> Advanced tab -> Incompatibility Fixes section.

    Regards,
    Oleg

    Thread Starter mladja11

    (@mladja11)

    Hi,

    Thanks for getting back. Yes, I am always having the latest versions of all plugins.

    No. “Fix for site with AJAX” does not work.

    And I discovered in the main time what exactly is causing the issue. It is deferring the JavaScript.

    If I disable that option in WP rocket, everything is fine, but if I turn the deferring on, filters are not working.

    However, I would like to defer JS, because that gives me better performance results…

    So, what do you suggest?

    BR,
    M.

    • This reply was modified 2 months ago by mladja11.
    Thread Starter mladja11

    (@mladja11)

    OK. I was busy today, I didn’t have time to join…

    So, does this issue appears on every website using these 2 plugins or just here? What about this one https://wordpress-512557-1846973.cloudwaysapps.com/kasse/tse-module/?

    This is how WPR interface looks like and also these are my settings for it. It works just fine like this, but if I would turn deferring on, filters are gone.

    What should we do?

    BR,
    M.

    Plugin Author Dima Holovnia

    (@dholovnia)

    Thank you guys. We are working now on fix for this issue. Will try to make it asap.

    Regards,
    Dima

    Moderator Yui

    (@fierevere)

    ゆい

    Plugin Author RazyRx

    (@razyrx)

    Hello,

    Please update plugin to latest version. It has some fix for WP Rocket and must solve this issue.

    Regards,
    Oleg

    Plugin Author Dima Holovnia

    (@dholovnia)

    Hello,

    It all depends on your server speed. You cannot cache all the variants of filtering. So it all depends on how fast is your server and database.

    From our side we are doing everything to make it faster(even creating custom pages to make better data structure).

    Regards,
    Dima

    Thread Starter mladja11

    (@mladja11)

    Actually, for me it does not work.

    Now the filters stop working even if the JS combining is active. Before, just deferring was a problem.

    Could you please take another look?

    BR,
    M.

    • This reply was modified 1 month, 3 weeks ago by mladja11.
    Plugin Author RazyRx

    (@razyrx)

    Hello @mladja11,

    Checked your site and plugin seems work correct, but your theme has some script that set height on products list.
    Did you changed something that fix issue?

    Regards,
    Oleg

    Thread Starter mladja11

    (@mladja11)

    Oh! Now I get it. Here it works: https://wordpress-512557-1846973.cloudwaysapps.com/

    But on other websites it is not working. Before I wrote my previous message, I checked the update from another website, which is basically a fresh WordPress installation.

    Why on some of the websites your change works and on some it does not?

    Thanks,
    M.

    [ Please do not bump. ]

    • This reply was modified 1 month, 3 weeks ago by mladja11.
    Thread Starter mladja11

    (@mladja11)

    Hi,

    It looks like this may be related with this topic. Actually, I am getting 404 error here:
    https://wordpress-512557-1894809.cloudwaysapps.com/marken/oberpos/

    That is a brand page. It looks like all the brand pages are returning 404 error, which is weird, cos I have here absolutelly the same setup and they work here:
    https://wordpress-512557-1846973.cloudwaysapps.com/brands/oberpos/

    Did I mess something up?

    Thanks,
    M.

    Thread Starter mladja11

    (@mladja11)

    Hi,

    Regarding the issues with WP Rocket on some of the websites, I just want to confirm that after this last update, that issue is gone as well.

    So, now everything works everywhere nice and smooth, like it is supposed to.

    Thanks,
    M.

    vincentengel

    (@vincentengel)

    Hello,
    Was there a solution for this. I have the same issue. Only after clearing my cache the filter works again.

    Kind regards,
    Vincent

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.