Support » Theme: Hueman » Adsense Responsive stopped working

  • Hello guys/gals,

    I’ve been meaning to post this but I have been very busy lately. I know that I should have made a child theme for this but I failed to do so. So anyways, I used to have the Responsive Adsense code for ”matched content” and it was working fine. It was inserted between the <head></head> tags in the Header.php file as instructed by Google. 2 Hueman updates ago it stopped working. If I do enter the code again, the ads will only show on the header area but not as matched content.

    Any ideas?
    All help is much appreciated and thanks in advance for your time.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • HI,

    As I know this needs two codes on the site.
    The code in the the Header php. is only the general “page level ads” code for displaying any page level ads.
    To display any single page level ad you should insert the -other –
    given individual ad code into a strict place like header or footer ad widget or sidebar html widget or…
    If you give no rules for matched content display, adsense will display it according to its best discretion, but for a time you can customize the display variations in your adsense account page.

    Where is the individual ”matched content” ad code on your site?

    Thread Starter ElTaino


    thanks a lot for your reply and time. For the sake of you getting to see the code, it was inserted again on the header.php. I could be wrong, but I don’t recall having to add two codes before. Again, I could be wrong on that.

    When the code was working on the old Hueman version, ads used to appear automatically between posts, either left or right side bars and on the ”MKR IS BROUGHT TO YOU BY:” Widget. The only manual code I used to insert, was the 728×90 on the banner space provided by the theme in customizer. Any ads you see on the side bars right now or within posts have been added manually because of the issue of not having them work with the new Hueman version. In the past, Google took care of all the placements.

    Thread Starter ElTaino


    If you look now, the header looks like a Taboola ad block on top of the page 🙁

    • This reply was modified 1 year, 11 months ago by ElTaino.

    Hi Mattia,

    Thanks for reporting this! It has been reported to the development team so they can look into it.

    Thank you!

    Hi ElTaino,

    1./The code (I see)you put into the header.php is the strict code of a ‘matched content’ window. That’s why you have the mash in the header.
    2. I don’t see any page level ad code in the header which is inevitable to display
    page level/automated ads. If this code is missing Google could not take care of automated ads placement on your site.
    Your page level adsense code in the header should be similar to this:

    <script async src="//"></script>
      (adsbygoogle = window.adsbygoogle || []).push({
        google_ad_client: "ca-pub-xxxxxxxxxxxxxxxxx",
        enable_page_level_ads: true

    1. So remove and put the code you have now in the header to the footer ad widget instead(or anywhere else into a widget)
    2. Enter into your adsense account,look for your ‘page level ads code’ and copy it
    into the header.php. after the<head> entry.(next line)
    3. Set your Adsense settings to automated ad placement, if it is not set so.
    4. The (automatic) ads will display on your site as before.

    I highly propose to create a Child theme, its very easy with Hueman. If not, all the additional codes will be disappearing at each and every updates.

    • This reply was modified 1 year, 11 months ago by kerdezo.
    Thread Starter ElTaino


    Sorry for the delay getting back to you @kerdezo .

    I will check this suggestion this afternoon and keep you guys posted.

    Thanks again for your time.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Adsense Responsive stopped working’ is closed to new replies.