Support » Plugin: WPtouch » Adsense ads not showing

  • Resolved n3m3



    I know that this issue has been discussed here extensively, however, no matter how I try, no ads show on my mobile page. (

    I’ve included my adsense ID number as directed by wptouch (with pub-), but maybe I’m doing something wrong with the Google AdSense Channel.

    Is it the id number of the ad, or is it its alpha name that has to be used?

    I’ve tried both, and still no go.

    Please help. Thanks.

Viewing 15 replies - 16 through 30 (of 30 total)
  • I think the best think to ask this quest was to google…

    or better use the Ad sense in non mobile sites.

    Folks, I guess there is no more Adsense for mobiles available. You have to use AdMob.

    @onlygators, you just need to enter your version of “pub-XXXXXXXXXXXXXXXX” provided in your Google AdSense code. Use your AdSense ID so your account can be found.

    Hello There !
    I am having responsive theme @ TechGYD yet t is quite comfortable with phones and other devices but still I wants to use WP Touch coz of it’s apple button, better customizations and all the things.
    Can I use this plugin in my responive website? It might show error ?

    Can I use this plugin in my responive website?

    WPtouch and WPtouch Pro can absolutely be used with responsive desktop themes. The responsiveness is CSS-based which will be fully compatible with WPtouch and WPtouch Pro.

    Keep in mind that only WPtouch Pro is built to accommodate advanced desktop theme functionality such as custom post types, custom page templates, and shortcodes. The free version of WPtouch does not offer these capabilities.

    I am new to this so simplicity would be a great help,
    i use Infoist theme and under my first 3 posts the google ads appear OK, but on right hand side of screen i have a skyscraper that is blank. How do i make that active for ads, i know that i would lose ads in other posts as i believe only 3 are allowed.

    @kiethg22 – It sounds like your question deals specifically with the desktop theme you have active. Please contact that theme’s author for help with your desktop theme.

    hey guys, I think I found the solution.
    Like BraveNewCode Inc. say, you need to make sure your “mobile ad” is active. What does that mean?

    Here is the solution.

    took me a while to figure this out but folks, you have to enter your Custom channel ID on the first box and leave the second one open. DO NOT enter your Publisher ID that starts with pub…use the channel ID. It took me about 30 minutes to figure it out for my site: The WPtouch dude on here is not that specific and confusing people.

    Thanks for the whole bunches of suggestions. It’s working for my site: Techmoody now.

    Amrik Virdi

    Tks @globalreachllc, ur post is the solution.

    My ads are showing, but only on ‘posts’. most of my site is made up of ‘pages’ and the ads do not appear. Any suggestions?

    Hi All! here is the sad truth, If adscense is not working on your Wptouch mobile site then you have two options but sadly if you are like me then option number two will leave you hating Google.

    1. Follow this link to activate Adscense for mobile.

    2. If option number one does not work then follow this link to check if your country is on the list of countries that adscense for mobile is available.

    Last resort, save up some money and purchase Wptouch Pro, from what I have heard, it supports the placing of full adscense code so your mobile banner adds should work. Wptouch looks awesome so I am off to save up some money. 🙂

    I can’t find the boxes to fill:

    For the ID field and id channel too…

    why is it?

    I have exactly the same problem that has n3m3, I’ve done everything as explained here and still can not get my display ads is

Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘Adsense ads not showing’ is closed to new replies.