Support » Plugin: Ad Inserter - Ad Manager & AdSense Ads » Ads or not showing on AMP Pages

  • Resolved singhvirat

    (@singhvirat)


    We have correctly configured the settings but Adsense is not showing AMP ads on the pages.

    Currently using AMP plugin to render AMP version of the site

    Ads are properly showing on non-amp pages. Query is for AMP pages only.

    AMP Mode: Reader

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Spacetime

    (@spacetime)

    Hello,

    the plugin only inserts ad codes, it does not display anything:
    https://adinserter.pro/faq/how-ad-inserter-works

    Therefore, we can mainly check if the blocks with ad codes are properly inserted.

    Your ad codes are wrong. You are inserting AMP code for Auto ads with each block – many times per page!

    NORMAL ADSENDE AD CODE
    
    [ADINSERTER AMP]
    
    <amp-auto-ads
      type="adsense"
      data-ad-client="pub-3292254548342962">
    </amp-auto-ads>

    And the AMP ad code reports the following – check the console in the browser:

    [amp-auto-ads] Auto ads for AMP aren't enabled for the provided publisher ID. Learn how set up Auto ads for AMP: https://support.google.com/adsense/answer/9011465.

    To insert AMP codes for individual AdSense ads:
    https://adinserter.pro/documentation/adsense-ads#amp

    To insert AMP code for Auto ads ONCE (if you enable them):
    https://adinserter.pro/documentation/adsense-ads#amp-auto-ads

    Thread Starter singhvirat

    (@singhvirat)

    Everything is already done as suggested by this article – https://adinserter.pro/documentation/adsense-ads#amp-auto-ads

    could you please check it again carefully?

    Plugin Author Spacetime

    (@spacetime)

    I see no change. Still wrong ad codes.

    Thread Starter singhvirat

    (@singhvirat)

    Separator is used for AMP

    PLEASE HIGHLIGHT THE ERROR, SO THAT ISSUE CAN BE MITIGATED.

    Thread Starter singhvirat

    (@singhvirat)

    or please share what is the correct code?

    Plugin Author Spacetime

    (@spacetime)

    Please carefully read the documentation pages – simply follow the instructions there.

    What is wrong I alredy described here:
    https://wordpress.org/support/topic/ads-or-not-showing-on-amp-pages/#post-15332688

    Thread Starter singhvirat

    (@singhvirat)

    Are you available??

    Thread Starter singhvirat

    (@singhvirat)

    Still not working.

    I think you are more interested in sharing your articles than resolving my problem.

    I ask you simply just tell me the issue but you are sharing your content every time.

    • This reply was modified 4 months, 4 weeks ago by singhvirat.
    Plugin Author Spacetime

    (@spacetime)

    Well, I described what is wrong with your ad codes and posted links to the documentation pages so you can see how to properly configure AMP ad codes for AMP pages.

    You inserting code for auto ads multiple times.
    This code needs to be inserted only once.
    And it needs script code in the header.
    You have Auto ads disabled for this website so it makes no sense to insert this code.
    And if you are inserting codes for individual ads then I would suggest to leave Auto ads disabled.

    To insert individual ads on AMP pages then you need to use (insert) AMP ad codes for ad units (not code for Auto ads).
    You can use built-in generator to generate (also) AMP ad codes.

    An example of such code:

    Plugin Author Spacetime

    (@spacetime)

    Instead of responsive code for “Below the fold” you can try AMP code for fixed ad size:

    <amp-ad
      layout="fixed"
      width=300
      height=250
      type="adsense"
      data-ad-client="ca-pub-xxxxxxxxxxxxxx"
      data-ad-slot="xxxxxxxxxxxxxx">
    </amp-ad>

    or responsive width and fixed height:

    <amp-ad 
         width="100vw" 
         height="320"
         type="adsense"
         data-ad-client="ca-pub-xxxxxxxxxxxxxx"
         data-ad-slot="xxxxxxxxxxxxxxxxxxx"
         data-auto-format="rspv"
         data-full-width="">
      <div overflow=""></div>
    </amp-ad>

    You also need to uncheck insertion on AMP pages as you are using AMP separator to automatically separate normal and AMP ad codes.

    Thread Starter singhvirat

    (@singhvirat)

    Thanks for your help sir. Now the issue has been resolved.

    Currently, I want to keep responsive ads as Google automatically optimizes them for AMP.

    Thanks a lot …..

    Plugin Author Spacetime

    (@spacetime)

    You are welcome.

    I would suggest to use the second format of responsive ads posted above – with fixed height.
    The origial responsive code seems to generate very high ad blocks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.