Support » Plugin: Advanced Ads – Ad Manager & AdSense » Ads Not Showing Unless I clear Cache

  • Resolved Sean

    (@wordjuicer)


    Has anyone else had this issue. Every time I reload the same page, the ad-sense ads stop showing, and only show again when I purge the cache on my site. But here’s the weird thing. I have site caching OFF and it STILL happens. Getting rather frustrated with it now. I am not sure if this is an ad-sense issue or an advanced ads issue. But if anyone else has run into this issue, how if at all did you resolve it?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support schmidt25

    (@schmidt25)

    Hi wordjuicer,

    Thanks for reaching out.

    Unfortunately, you did not specify the website where this issue appears.

    I took a look at the page that is linked in your profile. In the single posts, I could find a content placement with a slider. I also noticed the appearing AdSense ads when I loaded the page initially. Since the integration of Adsense in sliders does not comply with the Adsense policy, I would strongly advise you to take these ads out of the slider and deliver them via another placement instead.

    Have you integrated AdSense anywhere else than on this placement with the slider?

    Which plugin or service do you use for the (disabled) caching?

    I also noticed that the auto ads code was inserted several times and causes an error. You can find instructions on how to fix this problem here.

    Best regards,
    Joachim

    Thread Starter Sean

    (@wordjuicer)

    Autoads code was inserted several times by the advanced ads plugin, I never inserted it manually so advanced ads must have done that. But I never get errors regarding that. I have the adsense only in a widget at the top of my page beside my site logo, it shows ads on certain pages but I can’t see them unless I clear the cache every single time. I just have caching unselected in the main settings.

    Plugin Support schmidt25

    (@schmidt25)

    Hi wordjuicer,

    Thanks for your reply.

    Advanced Ads injects the Auto Ads code only once when the auto ads code is enabled (Advanced Ads > Settings > AdSense). This issue seems to be fixed now.

    I can see an AdSense code near the logo that doesn’t seem to be injected with Advanced Ads. However. The code is calling AdSense and receiving data.

    Which plugin or service do you use for the (disabled) caching?

    Best regards,
    Joachim

    Thread Starter Sean

    (@wordjuicer)

    This is the thing that is wrecking my head. Up near the logo, is a widget that is part of the theme template that never gave issues before. This widget has advanced ads applied to it yet my ads are just simply not showing.

    Plugin Support schmidt25

    (@schmidt25)

    Hi wordjuicer,

    Which plugin or service do you use for the (disabled) caching?

    Thread Starter Sean

    (@wordjuicer)

    I don’t use any plugin. In cache levels in settings I have set to 0. But I don’t think cache was the issue either. Now it seems ads are not showing across my sites at all and according to the ad sense account there are no violations.

    Plugin Support schmidt25

    (@schmidt25)

    Hi Wordjuicer,

    I checked this website and notice that AdSense and other ads appear, including the widget next to your logo.

    Does your issue persist?

    I asked for a caching plugin because you reported that your website shows ads on specific pages, but you can’t see them unless you clear the cache every single time.

    Best regards,
    Joachim

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Ads Not Showing Unless I clear Cache’ is closed to new replies.