Support » Plugin: Ad Inserter - Ad Manager & AdSense Ads » Ads Not Displaying for Adsense Auto Ads

  • Resolved rebornhairppp

    (@rebornhairppp)


    Hello,

    After reading through the Troubleshooting tips found here: https://adinserter.pro/adsense-ads#ads-not-displayed

    I wanted to make sure I followed everything correctly. As of last night, I have given Google the green light to display AUTO ads on my website. I know this process can take up to 3 days. However, I don’t even see blank ads displayed during the interim.

    I haven’t pre-configured any blocks on your plugin. All I did was insert the code provided by Google into the header section under settings.

    When I am on my homepage and click Label Blocks, I see a turquoise header banner at the top named Code for AdSense Auto Ads detected – Code will automatically insert AdSense ads at optimal positions. I also see my Google Adsense auto ad code in the body section of this ad banner.

    However, I don’t see any Label blocks in the beginning, middle, and end sections of my homepage paragraphs. The turquoise label block is only on the very top of the page (i.e. header). I am thinking this is due to me not setting up any blocks in the configuration settings because I want Google to decide the optimal areas of placement.

    Please note, I have turned off all Ad blockers in my browser’s settings.

    I just want to make sure this behavior is normal. So it will only be a matter of time for the ads to display contingent upon Google’s approval. Correct?

    Thank you so much for your help and guidance!

    All my best,

    Joe

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Spacetime

    (@spacetime)

    It seems the code for Auto ads hasn’t generated any ads yet.

    You didn’t post any web address so we can’t check.

    Here is my website homepage: http://www.resurrectedhair.com

    Plugin Author Spacetime

    (@spacetime)

    You have Javascript errors on the page:

    Refused to load the script 'https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js' because it violates the following Content Security Policy directive: "script-src 'unsafe-eval' 'unsafe-inline' https://www.google.com https://www.resurrectedhair.com *.googleapis.com https://*.jsdelivr.net *.jquery.com https://apis.google.com/js/plusone.js https://apis.google.com/_/scs/apps-static/_/js/k=oz.gapi.en.Hz_fKt4joNY.O/m=plusone/rt=j/sv=1/d=1/ed=1/am=AQE/rs=AGLTcCNxa6hEp_2ZA4OZrE34DKYVz1z2BQ/cb=gapi.loaded_0 https://apis.google.com/_/scs/apps- static/_/js/k=oz.gapi.en.HC2g6SRsg_U.O/m=plusone/rt=j/sv=1/d=1/ed=1/am=AQ/rs=AGLTcCPz5Aj2-ryLqteRLkIrqMk6EuzCaQ/cb=gapi.loaded_0 https://static.addtoany.com/ https://static.addtoany.com/menu/page.js connect.facebook.net platform.twitter.com apis.google.com graph.facebook.com https://www.google-analytics.com/analytics.js https://www.google-analytics.com/plugins/ua/linkid.js".

    Yes, I just noticed that. I had content security policies implemented disallowing Google ads. I renabled it so those errors are no longer present.

    I now only have a Failed to load resource: the server responded with a status of 403 ()

    After reading this thread: https://stackoverflow.com/questions/37236229/google-adsense-responding-the-server-responded-with-a-status-of-400, I believe it’s normal for newbies until Google approves your site.

    Please let me know if you see any other errors.

    Thank you for the suggestion.

    Plugin Author Spacetime

    (@spacetime)

    You still have issues with security.

    I just turned off content security settings. I still see the 403 error. Do you see any additional security issues? I also have CloudFlare installed, but I am not sure if I need to modify those settings as well.

    Plugin Author Spacetime

    (@spacetime)

    Try without CloudFlare.

    Yea I tried to pause Cloudflare. No luck. I don’t think the issue has anything to do with Cloudflare.

    Are you only just seeing the 403 issue? If so, I think it’s normal based on the stackoverflow response.

    I will try sending feedback to Google.

    Plugin Author Spacetime

    (@spacetime)

    Yes, only 403.

    Ok.

    I noticed something strange. When you click on View Page Source, and search for google_ad_client, do you see on your end a breakage of the adsense code?

    Rather than showing:
    <script async src=”//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js”></script>
    <script>
    (adsbygoogle = window.adsbygoogle || []).push({……….

    On my end it shows:
    a lot of other text before this code </style></noscript><script async src=”//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js”></script>
    <script>
    (adsbygoogle = window.adsbygoogle || []).push({

    Is this normal.

    All I did was insert the code in the header tab under settings. I didn’t add any blocks nor changed any of the default settings.

    Would I need to play around with any of the other plugin’s settings?

    Thank you for taking the time to investigate this issue. It’s really draining our time and it shouldn’t be this hard.

    I got an email from Google telling me they denied my request due to being unable to access my site. Supposedly it was down (which it wasn’t) so their weren’t able to review my request.

    Plugin Author Spacetime

    (@spacetime)

    Nothing unusual in you code.
    The code for adsense Auto ads is properly inserted.

    I still see errors:

    Failed to load resource: the server responded with a status of 403 ()

    Thanks for the confirmation. I know I still don’t know what it’s due to.

    Let me get one thing straight. Even though Google is still in the process of reviewing my site, I still shouldn’t see this 403 error and blank ads should be displaying for the time being, correct?

    Plugin Author Spacetime

    (@spacetime)

    Blank ads are displayed when using normal ad unit code and Google doesn’t want to serve ads.
    Code for Auto ads doesn’t insert ads in such case.

    Maybe this can help:
    https://www.shoutmeloud.com/adsense-403-forbidden-error.html

    Ok that’s good to know.

    Thanks for the article. I did follow all the steps last night except #2 and #3. For #2, I don’t even see My Sites In my Adsense account under Gear icon -> Settings -> My sites -> Manage sites.

    After reading the forums, I believe Google first needs to approve of your site serving ads before this option becomes available.

    I will check with namecheap to see if they have any mod rules enabled.

    I strongly believe the 403 issue is normal before approval, based on other responses I have seen in other forums.

    Ok so I found a pretty good answer on this: https://webgilde.com/en/adsense-403-error/

    “If you look at your site through the error console of your browser, you might see an 403 error for the url requested by the ads. This means your ads are not approved yet.

    The approval of an AdSense account does not automatically include your hosted domain. If you requested the approval of your own domain, you are asked to include ads into your site, so AdSense can review it. This can take a few days to over a week.

    The only thing you can do now is to check if your ad code is inserted correctly. Just compare the code you got from AdSense with the code your browser displays.

    As hard as it is, you must be patient now.”

    Per your confirmation, my ad code is inserted properly, so now it’s just a waiting game I suppose?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Ads Not Displaying for Adsense Auto Ads’ is closed to new replies.