• Hello, I would like your help, please. I maintain a channel on YouTube with cooking recipe content. I have created a blog on WordPress, and in each article, I embed the video with each recipe. When the visitor plays the video through the article, it starts without the ads as it would if opened on YouTube, resulting in me losing revenue from the ads. Is there a way for the ads to play in each video embedded within the articles? Τhank you in advance.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You have to set this in your YouTube profile, see: https://support.google.com/youtube/answer/132596?hl=en

    Thread Starter dimitrismat

    (@dimitrismat)


    Thank you for your feedback, but YouTube states that in order for ads to work, you need to add the video embedding code to WordPress, which cannot be done. It only works with the URL, but ads don’t play. I also tried the embedding option and the WordPress embedding code option, but the video embedding code doesn’t execute.

    • This reply was modified 3 months, 3 weeks ago by dimitrismat.

    Now the question is how exactly do you try to embed what in which editor?

    In the block editor there is the Youtube block: https://wordpress.org/documentation/article/youtube-embed/ – do you use it? If so, which URL are you inserting here?

    If you are using something else, please feel free to show a screenshot. You can upload it here, for example: https://imgur.com/

    Thread Starter dimitrismat

    (@dimitrismat)

    Hello, I apologize for my poor English, and I hope you can understand me. I’m having trouble with my WordPress website. I’ve embedded a YouTube video in one of my articles, but the ads aren’t playing. From what I’ve researched, it seems that unfortunately, this cannot be resolved. I’m sending you an example from my blog where I’ve embedded a video from my spouse’s channel. If you see, the video plays fine when you press play, but the ads don’t run, which means I’m not getting paid.

    Here is an example

    https://www.konstantinas-kitchen.gr/nostima-kai-aromatika-biftekia-ryziou-sto-fourno/

    I see that you are using the YouTube block mentioned above to embed the video on your page. This is actually the right way from a WordPress perspective. Unfortunately, I don’t know what YouTube means by

    but YouTube states that in order for ads to work, you need to add the video embedding code to WordPress

    That’s actually exactly what’s happening here.

    I just have an alternative idea: use the embed code that YouTube provides for your video. You can find it as described here: https://support.google.com/youtube/answer/171780?hl=en – in WordPress you then use the HTML block to insert the code.

    If that doesn’t help either, I would recommend that you contact a community that provides YouTube support, e.g. here: https://support.google.com/youtube/?hl=en#topic=9257498

    Thread Starter dimitrismat

    (@dimitrismat)

    Thank you very much for your help. Unfortunately, I have tried that as well, but with no results. The video plays normally, but it still doesn’t display ads. I left a comment and a question on the link you sent me in the YouTube community. Once I receive a response, and in case I manage to solve it or not, I’ll come back to let you know what happened. Thank you very much for your time!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.