Support » Fixing WordPress » Admin/Manage/Uploads no longer functions after upgrade from 2.0.2 to 2.2.3/2.2.3

  • ClaireBrewer


    I run WordPress on an internal server (SunFire 280R, Solaris 5.8) with the following software versions from phpino:
    PHP Version 5.1.0RC1
    Apache/1.3.27 (Unix) ApacheJServ/1.1 PHP/5.1.0RC1
    mysql Client API version 4.1.14

    Before the upgrade (from 2.0.2 to 2.2.2) my colleagues were able to upload files using Admin/Manage/Uploads but they needed to use the WP-Stats plugin. This didn’t work with that version of WordPress so I upgraded to WP 2.2.2. Stats worked, as did everything else except the Upload files. I’ve since upgraded to 2.2.3 and now to 2.3 and this issue is not fixed.

    Clicking on the Upload link gives me a blank page in the latest Firefox on the Mac, on Safari3.x on the Mac I get “Safari can’t open the page “” because the server unexpectedly dropped the connection, which sometimes occurs when the server is busy. You might be able to open the page later.” and “the page cannot be displayed . The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.” in IE on Windows. There is no problem with my webserver. All other pages are being served properly and all other functions are working in WordPress.

    I have:
    installed WordPress on my Mac using the same WP source. I can upload.
    used the source files on the server above on my Mac, I can upload
    Created a new instance of WordPress with a new table prefix on my server, upload gives the same errors above.

    If I insert a phpinfo (); line into wp-admin/upload.php I get the PHP info displayed. The location of this line in the file affects how much info is displayed eg. if I enter it after “if (!current_user_can(‘upload_files’))…” i see info until “PHP License” but then it stops and nothing else is displayed. If phpinfo(); is entered after “require_once(‘admin.php’);” the last section of PHP info is PHP Variables.

    Can anyone shed any light on why things aren’t working or offer any suggestions on where to look for where things are breaking?

    Cheers, Claire

Viewing 6 replies - 1 through 6 (of 6 total)
  • ClaireBrewer


    Anyone??? 🙁

    Sorry to reply to my own post again, but is there *anybody* who might be able to help me with this problem?


    I can’t really help, but can point you to trac where there is a similar problem reported:

    The fix listed above has not made any difference to what’s happening with my blog, there still seems to be an error in wp-admin/upload.php that stops the page from loading.

    I just recently upgraded from 2.2.0 to 2.3.1 and am experiencing a similar problem. Whenever I load a page that hits wp-admin/upload.php, I get an Internal Server Error. This includes Manage->Uploads, Write->Write Post, and Manage->Posts (the latter two display the error in the frame that holds the file upload form).

    When writing or editing a post, the file upload form can have up to 3 tabs: Upload, Browse, and Browse All. I only receive the error on the Browse and Browse All tabs. I can successfully upload a file, but when the frame reloads, I get the error, presumably because it is trying to display the Browse tab.

    I do my development locally on a laptop running Windows XP and fairly recent versions of Apache, PHP, and MySQL. The error does not occur in that evironment, only on the installation on my web host’s server. Thinking it may have been an issue with the upgrade, I tried a fresh install, but the error is still there.

    I have pored over the documentation to see if some configuration requirement for uploads has changed since the version I upgraded from (since this feature was working fine before) but have not found anything.

    If anyone has any idea what the problem might be, I’d appreciate it.


    I’ve done some investigation and the problem apparently started with version 2.1.0 when wp-admin/inline-uploading.php was replaced by wp-admin/upload.php and some other supporting files.

    My upgrade path was 2.0.10 -> 2.1.0 -> 2.2.0 -> 2.3.1. I guess that wasn’t paying enough attention to see the problem 2 upgrades ago. Otherwise, everything else I wrote still applies.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Admin/Manage/Uploads no longer functions after upgrade from 2.0.2 to 2.2.3/2.2.3’ is closed to new replies.