Support » Plugin: Acunetix WP Security » Administration

Viewing 12 replies - 1 through 12 (of 12 total)
  • Mee too. Have same problem. Bad coding i think…

    Deactivating & re-activating the plugin worked for me. Shows as “WP Security” in the bottom group in the site admin menu.

    Deactivating and reactivating seems to work for people who already had the previous version and updated it to 4.01, although not for everyone. But for people (like me) that freshly installed only the 4.01 (never used the older one), nothing seems to work. Seems we can only wait for the 4.02 ^^

    Plugin Author Acunetix


    Hello guys

    We are very sorry to hear about these issues, but nothing like this happened on our tests…

    Please follow these steps to have this fixed:
    – first login to your wordpress administration panel; from there please deactivate the plugin and delete its files
    – then, login to your website’s cpanel and navigate to the phpMyAdmin section and open up the database. From there, check to see whether or not the following tables exist:
    – _wsd_plugin_alerts and _wsd_plugin_live_traffic

    If they exist, please delete them.

    After that, open the SQL tab and run the following query:

    Don’t forget to change the YOUR_OPTIONS_TABLE with the name of your current options table.

    This will clear every option the plugin has stored in the database.

    After you have done this, you can go back to your website’s administration panel and install again the plugin. From here on you should not have any issue with it.

    @varkhan: did you happen to have installed a version of the Secure WordPress plugin? because if you do, then there might be a conflict between the two – although, the latest versions of the plugins can be run at the same time without any problems…Can you please let us know what you mean by “nothing seems to work”?

    Thank you for your understanding


    Hi ‘Acunetix’,

    “@Varkhan: did you happen to have installed a version of the Secure WordPress plugin? because if you do, then there might be a conflict between the two – although, the latest versions of the plugins can be run at the same time without any problems…”

    No, I’ve got those plugins installed :

    BulletProof Security (disabled)
    CKEditor for WordPress
    Recent Posts Widget Extended
    UpdraftPlus – Backup/Restore
    WP Editor Widget

    and that’s all…

    “Can you please let us know what you mean by “nothing seems to work”?””

    Well, the plugin doesn’t seem to work, as
    1) there are as reported by the others no Settings button/link available
    2) nothing seems to be done (no messages from the plugin) but that’s hard to judge as is

    Any idea (deinstalling and reinstalling shouldn’t do anything good, there was no previous version). Also, my 3.6.1 WP is the FR version and not the US, if that matters..

    Plugin Author Acunetix


    Hi Varkhan

    Thank you for your reply. At this point, I suggest you to go trough my previous post and check the database. It seems that there might be a database issue rather than the plugin.

    Can you please go through my previous post and follow it step by step and let us know if the problem persists?

    Thank you in advance

    Best Regards,

    Hi Acunetix,

    You’ll see there ( the existing databases on my side : no sign of any _wsd_plugin_alerts and _wsd_plugin_live_traffic.
    And the plugins do not show in the admin menu …

    If it can be useful, here are the existing databases with the Secure WorPress and WP security Acunetix plugins installed ans activated … No difference.

    I also noted that the Dashboard and the Plugins does not show any updates available for my wordpress installation (NextGen gallery provides an update and there was a number 1 besides theses two tabs).
    I have to get into the plugins page to see the available update …

    Still no luck … waiting for a working advice …


    Plugin Author Acunetix


    Hi, guiliguili

    Thank you for your feedback.

    From what I see, if the tables are not present after you click the install plugin button/link then the most reasonable explanation is that your db user (see wp-config.php file) does not have the needed rights create or alter the database.

    Can you please check that out and give the db user appropriate rights?

    Thank you


    Hi ” Acunetix “,
    Thanks for your involvement.
    I can’t access to thedb privileges with my hosting company, being on a mutualised server.

    Moreover, I am pointing the fact that previous version of this plugin worked flawlessly.
    Did you change the plugin on this particular point ?
    If so, there should be much more complaints and much more resolved inbstallation of this plugin.

    Still waiting for a fix …

    Plugin Author Acunetix


    Hello guiliguili

    Thank you for your feedback.

    As I’ve told you above, this version of the plugin comes with new features and those required new tables in the database. Thus, when the plugin is installed we try to create them. In your case, since the tables don’t show up in your database we came to the conclusion that your db user doesn’t have the appropriate rights, you could check it easily using your website’s COntrol Panel or you could check it with your hosting provider.

    Also, can you please check your log files, there might be valuable information that we could use to track down this issue.


    It seems like the only sites I’m having this issue on (and isn’t solved by simply deactivating & reactivating) are those running IIS on a Windows server. Sites running a LAMP setup appear to be working fine. Wonder if this is similar for others.


    Checked Box in Settings page are not availables (and also Clear All button).

    I try the issue (delete plugin, clear database…) but it doesn’t work…


Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Administration’ is closed to new replies.