• Resolved stef1964

    (@stef1964)


    Hello Frank,

    I’m using Adminimize since yesterday and I’m very happy with it!
    But one thing is not clear to me, maybe it’s a bug or maybe I forget to check a certain box?

    Based on role “Administrator” I disabled the entire area “Settings”. The WP-Settings (read, write, permalinks, etc) and also all the settings for the plugins are located there. So I don’t want my client to work there.

    But I allowed the area “plugins” (not for install new plugins, but only to see installed plugins and update them).

    The problem is: when my client clicks on “plugins”, all the installed plugins are listed there, also the plugin “Adminimize”. When he clicks on “Adminimize Settings” then he jumps to the area “settings” (which is suddenly visible in the admin-menu) and he could change all the settings of the Adminimize-plugin! pooh!

    All the other plugins don’t have that problem. e.g. when he clicks on “Antispam Bee Settings” then the message pops up: “You are not allowed to change these settings”.

    Why does’nt that work with the “Adminimize Settings” ?

    Thank you for an answer.
    Best regards
    Moriaan

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Frank Bueltge

    (@bueltge)

    Hi.
    Adminimize hide! areas. There is now bridge to rights, capabilities in roles. If you hide areas it is often possible to find a other way to this area for users, there have enough knowledge. Since 1.11.* is also a function include that prevent the access for pages, there are hide in the menu settings. But yes, a user there have access to plugins, have also access to links, areas in this page. You can also hide areas in this page, but this is only to hide this area, not prevent the access.

    Thread Starter stef1964

    (@stef1964)

    Hallo Frank,

    erstmal Danke für Deine schnelle Antwort. Ich schreibe mal in deutsch zurück, das ist für die Kommunikation irgendwie doch leichter 😉

    Was mich eben wundert: bei allen anderen Plugins kann ich (bzw. der Client-Zugang) die “Einstellungen” aufrufen, dabei bekomme ich dann immer die Meldung: “Du bist leider nicht berechtigt, auf diese Website zuzugreifen”. Nur bei den Einstellungen von Adminimize wird mir diese Meldung nicht gezeigt. Stattdessen bekomme ich das gesamte Mini-Menu angezeigt. Und im Admin-Menu links sind auch wieder alle Einträge sichtbar, die ich vorher für den Client-Zugang versteckt hatte.

    Also nur bei den Adminimize-Einstellungen scheint mein Kunde dann doch Zugriff zu haben…

    Hast Du eine Idee, woran das liegt?

    Vielen Dank!
    Moriaan

    Thread Starter stef1964

    (@stef1964)

    Hier noch ein Screenshot:
    Screen

    Plugin Author Frank Bueltge

    (@bueltge)

    Das ist korrekt, da Adminimize auf der Seite der Einstellungen aller Filter ignoriert. Nur so kann Adminimize die Felder aus der jeweiligen Installation dynamisch ausleiten, generieren.
    Du musst also max. das Feld Einstellungen zu Adminimize ausblenden, via custom (own) global options. Alternativ kannst du auch die ganze Zeile ausblenden.

    Thread Starter stef1964

    (@stef1964)

    Hallo Frank,

    vielen Dank für deinen Support!
    Ich finde leider nirgends eine Dokumentation darüber, wie diese custom css options zu benutzen sind. Das feld “Einstellungen” oder besser noch: die ganze Zeile ausblenden? Ja, eine super Idee! Aber wie? Und wo?

    Über den Firebug finde ich für die Plugin-Zeile diese Angabe:
    <tr class=”active” data-slug=”adminimize” data-plugin=”adminimize/adminimize.php”>

    Kann ich jetzt irgendwo in den Einstellungen festlegen, dass diese Zeile verschwinden soll?
    z.B. tr .active {display: none}

    Geht das?
    Danke und schönen Gruß
    Moriaan

    • This reply was modified 7 years, 6 months ago by stef1964.
    Plugin Author Frank Bueltge

    (@bueltge)

    Ja, kannst du.

    Die Doku ist bspw. im FAQ zu finden, alternativ die readme des Plugins lesen, darin sind die Links.

    In deinem Fall ergänzt du in den “Global Options” im linken Feld ein Name bspw. Plugin List Adminimize, rechtes Feld der Selektor data-slug='adminimize'. Nun aber das Problem. Aktuell kann Adminimize diese besonderen Selektoren nicht nutzen. 🙁 Dazu brauchen wir ein Update. Ich erkenne aber auch keinen einfacheren besseren Selektor. Du kannst aber so lange den nth selektor nutzen. Also rechts folgendes rein – tr:nth-child(9). Die Zahl ist die Zeile der Tabelle, in der Adminize als Plugin steht. Nach den Einträgen die Einstellungen updaten, und die Checknox pro Rolle wählen, wieder updaten. Danach sollte die Zeile weg sein.

    Thread Starter stef1964

    (@stef1964)

    Vielen Dank !!! Klappt super!
    Ja, die “Beschreibung” im FAQ-Bereich hatte ich bereits gelesen, konnte mir aber trotzdem keinen richtigen Reim drauf machen, wie das genau einzusetzen ist.
    Spende ist unterwegs 🙂

    Viele Grüße
    Moriaan

    Thread Starter stef1964

    (@stef1964)

    ooh, leider gibt es hier doch noch ein erhebliches Problem. Denn unter dem Client-Zugang wird jetzt nicht nur die erste Plugin-Zeile versteckt (ich hatte tr:nth-child(1) eingetragen), sondern es werden auch alle anderen “ersten Zeilen” ausgeblendet! D.h. auch die Beiträge, Seiten und Custom Post Types stellen nun ihre Listen ohne die erste Zeile dar, es fehlt also immer die erste Seite in allen Listen! So kann das natürlich nicht bleiben. Gibt es denn noch eine andere Möglichkeit, wie ich speziell nur die erste Zeile der Plugins ansprechen kann?

    Danke und viele Grüße
    Moriaan

    • This reply was modified 7 years, 6 months ago by stef1964.
    Thread Starter stef1964

    (@stef1964)

    sorry für den Aufruhr, es war nun doch ganz einfach 🙂 .plugins tr:nth-child(1)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Adminimize-Settings should be disabled, but are not’ is closed to new replies.