WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Adminimize custom options disappearing – can't reactivate

[Resolved] Adminimize custom options disappearing – can't reactivate

  • I’m using Adminimize to remove taxonomy options for a custom post type. I add the options correctly and they appear in the list after updating. The settings are also deactivated for that user role. When I re-login as Admin, the custom option is gone but the settings remain – so I can’t uncheck the box to deactivate.

    Is this an issue with custom post types? I’m running 1.719 on WP 3.21.

    I’m also using Role Scoper – are there any known incompatibilities with these 2 plugins?

Viewing 15 replies - 1 through 15 (of 15 total)
  • i’m still having this issue too, but we couldn’t track a cause…

    brand new install, only Adminimize active

    for me, the only stable version to work with wp3.2.1 is adminimize 1.7.12
    – it lacks specific hacks for wp version 3.* , but gets the job done

    Same issue here : i deactivate screen option for a specific role in “wp nav menu options / option”, and i can’t activate it now ! (i guess i will do this in the db so for now…)

    Looks like many options are note reloaded when we come back later in adminimize.

    note : i used “members” plugin for managing new role

    I’m experiencing the same thing.
    but it appair to happen only on custom post type.
    on posts and pages they remains.

    on cpt they disappair both in checklist that in textarea

    I have the standard wp roles, just changed some capabilities using “user role editor” plugin

    Here there’s someone else having the same issue: http://wordpress.org/support/topic/custom-post-types-and-your-own-post-options-issue?replies=3#post-2373694

    Tis still an issue but a workaround is to put your rules in the Global Options.

    OMG, finally someone acknowledges there’s a Houston going on here

    thanks, jonah!
    i was thinking it was karma or some other mystic stuff happening

    but, btw, do you have inside knowledge? as in “Tis still an issue…”

    Tis still an issue but a workaround is to put your rules in the Global Options.

    @jonahcoyote, thanks for your tip, but I’m a bit slow… can you please explain this better?

    I just discovered that if you activate “Exclude Super Admin” (in theory a feature only for MultiSite) the plugin stabilizes
    – you won’t be able to hide stuff for a regular Administrator, but at least you can deal with the options without them hiding in the plugin options page and you not being able to deactivate/manipulate them

    Hi brasofilo,
    I tryed to exclude super admin, as you suggested, but hidden properties remains hidden. Thanks anyway for sharing 🙂
    Someone else tried this config?

    hi, bluantinoo,
    you can try
    – export your config to have a backup
    – reset the plugin
    – start over

    brasofilo,

    thanks for the tip. I tried your suggestions: exported config, reset plugin, exclude super admin, started over. Still the same issue. I’ve even updated to the latest plugin version w/ 3.3.1. It’s very frustrating since I’m running this on a CMS setup w/ over 250 people as contributors. I really need to hide certain fields!

    Anyone else succeed?

    @troque: please can you send me the exportet options and a list of all active plugins, also you CPT plugins?
    I will check this for debugging.

    @frank, I’ve sent an email with exported options and other info that might help with debugging. Thanks very much!

    It looks like Version 1.7.27 fixes this issue! Thanks very much!!

    I’m also running WP version 3.2.2 (most recent version).

    fine, thanks for reply.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] Adminimize custom options disappearing – can't reactivate’ is closed to new replies.