WordPress.org

Support

Support » Plugins and Hacks » Toolbar Theme Switcher » Adminbar not displaying after switching theme

Adminbar not displaying after switching theme

Viewing 6 replies - 1 through 6 (of 6 total)
  • Do you get any error messages with WP_DEBUG enabled?

    Does toolbar work properly with that theme if you switch to it via usual means?

    Yeah:
    Warning: Cannot modify header information – headers already sent by (output started at /wp-includes/functions.php:3041) in /wp-content/plugins/toolbar-theme-switcher/toolbar-theme-switcher.php on line 259

    And I do not understand your last question at all.

    That indicates that something else is sending output before switcher and at that point no output should be happening yet.

    And I do not understand your last question at all.

    If you disable plugin and switch to theme normally in admin, does toolbar work properly?

    It appears your plugin is not at fault here for the adminbar not showing up.

    Sorry to waste your time on this. Unless that error is not normal?

    However due to your plugin I’m unable to activate any other theme but the current theme. And that is a serious bug.

    And for some odd reason that plugin keeps activating the same theme over and over when activating the plugin…

    When deactivating the plugin the theme goes back to the other one. The one it was before the plugin got activated. Which is good.

    Something in your setup is sending output to browser before it should and it’s likely interfering with my plugin setting cookies for theme choice.

    I imagine if you figure out what that is and fix it – my plugin would work just fine for you.

    I could try to activate each plugin one by one?

    Maybe its an other plugin causing it.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Adminbar not displaying after switching theme’ is closed to new replies.
Skip to toolbar