Support » Fixing WordPress » Admin widget drag and drop not working

  • Hello all,

    I can’t seem to figure out why in my widget admin menu I can’t drag and drop. I had a fresh local install of wordpress 3.0.1 with all the same plugins as my live site, but drag and drop only works on my local site.

    I’ve disabled all plugins and reverted to the default theme but it still doesn’t work.
    Here is the site: http://www.durhamdigs.ca/

    cheers,
    jim

Viewing 15 replies - 1 through 15 (of 22 total)
  • It is very hard to diagnose this problem but it is most likely one of the following:

    • JavaScript is disabled in your browser
    • WordPress is not loading the JavaScript because of a bad link.
    • There is an error in the JavaScript.

    I would recommend download all the files from WordPress.org again and replacing all the files apart from the wp-content folder.

    If that does not fix it try installing the Firefox plugin firebug to see if there are any JavaScript errors – http://getfirebug.com/.

    Does the rest of the JavaScript in the admin work. The accordion menu on the left side, collapsing your dashboard widgets, the wysiwyg editor on edit posts page?

    Dave.

    The rest of the menus work. the menus on the left slide down like they are supposed to. The screen options at the top slides down.

    “The accordion menu on the left side, collapsing your dashboard widgets, the wysiwyg editor on edit posts page?”
    all of these still work.

    It seems to just be the widget menu that is not working.

    I am using the same browser for both the local and live site. firefox 3.6.8. I also tried it in ie8 and it’s a no go there as well.

    There is no javascript errors in firebug.

    I’ll try replacing all files except the wp-content folder and see if that fixes it.

    Cheers,
    Jim

    I just replaced all the files except the wp-content folder and it still does not work. I also tried the automatic reinstall of wordpress 3.0.1 through the dashboard and that did not fix it either.

    Can you think of anything else?

    Thanks for your input daveredfern.

    I am having the same problem. Running 3.0.1 and all the JS in the admin UI seems to work except for drag-and-drop in the custom menu UI (which basically cripples that feature). I have tried in FF, IE, and Chrome, and all fail. Firebug reports this JS error as soon as I try to drag any menu item:

    this.helper.scrollParent is not a function
    /wp-admin/load-scripts.php?c=1&load=hoverIntent,common,jquery-color,jquery-ui-core,jquery-ui-draggable,jquery-ui-droppable,jquery-ui-sortable,wp-ajax-response,wp-lists,postbox,thickbox,media-upload&ver=6a1a86f09dc1f6c4a619b25927c8fa5c
    Line 56

    I tried a 3.0.1 reinstall and cleared my cache, to no avail. Please help?

    Thanks!

    Jim

    Ah, sorry to be a bother, disabling plugins got it working, so I guess I have some rogue code in there. Thanks!

    Does anybody have another idea on how to solve my OP?

    If you’re still having a problem, try installing the Use Google Libraries plugin, as recommended by a user from this message:

    http://wordpress.org/support/topic/widgets-dont-drag-and-drop-as-advertised/page/3?replies=76

    I had the same problem where all other javascript in the WP admin area was working but the drag and drop for the page menu’s wasn’t. I installed the Google Libraries plugin and amazingly that seemed to fix the problem. Not exactly sure why because all javascript was loading correctly and I had every plugin disabled but at least it’s working again.

    Hi,

    I also had a problem with drag and drop of the widgets after enabling wordpress 3.0.1 mu.
    After disabling all plugins I found out that the hRecipe
    (http://tinobox.com/wordpress/hrecipe) broke the drag and drop.
    The drag and drop did work on the sub-pages (xx.kookblog.nl), it was only the main page (kookblog.nl) where drag and drop was broken.

    Best regards,

    dirk adamsky

    Thank you!!! (about the Google Libraries plugin)

    This kind of problems usualy are coused by asp tags disabled.
    Turn it on, on your php.ini

    I have been tearing my hair out for three days now with the same problem, FIXED by the “Use Google Libraries ” plugin. My site also loads much more quickly now as well. One Happy Bunny!!! Thanks for all who posted here

    +1 for Use Google Libraries. It solved my drag and drop problem with the Widgets admin page. It rocks.

    I had the same problem. The Google Libraries plugin fixed it and is brilliant all the way around. Thanks for the tip, oldguy!

    Same for me! (Google Libraries plugin) fixed my problems with drag and drop and left menu!

    Thank you all

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Admin widget drag and drop not working’ is closed to new replies.