Support » Plugin: User Role Editor » Admin vs Super-Admin Capabilities in Multisite

  • Resolved pixieblitz


    I feel silly, but I went through and disabled a bunch of the capabilities for “administrator”, because that’s the default role for users who sign up to create a new blog. After the changes went through, those options are now no longer showing up at all. I can’t enable them for ANY roles, which is pretty inconvenient. I tried deactivating and even deleting and reinstalling the plugin, but they’re not coming back.

    …any ideas? And IS there any way to edit the regular admin role without interfering with the super admin?

Viewing 2 replies - 1 through 2 (of 2 total)
  • I ended up resolving it in a roundabout way… Since pressing “reset” was changing absolutely nothing (I think it may not have even been registering, since there was no warning pop-up when I clicked it), I tried changing one of my test users to a super admin.

    After I logged in as the test-user with a superadmin role and went to the URE settings and clicked “reset”, the warning message popped up and the missing options showed up again. I have no clue why it wasn’t letting me do this as the original network superadmin though. (It also doesn’t seem like the superadmin privileges were affected since I could still DO everything in the rest of the wordpress admin area, just not edit the missing capabilities in URE that were no longer showing up on the list.)

    And just to be clear the “missing” options weren’t grayed out or anything, they were literally not showing up on the list. 😛

    Anyway, thank you for a great plugin!

    Plugin Author Vladimir Garagulia


    Thank you for the information.

    There is no special role for the superadmin. “superadmin” is just a sign, that user is the “God” for the whole WP multi-site network.

    I have no clue why it wasn’t letting me do this as the original network superadmin though.

    I suppose that some JavaScript error could occur, as you did not see the warning message when press “Reset” button. Please check browser’s JavaScript console.

    “Capability missing after excluding it from the administrator role” is known bug – the fix for it will be available with upcoming version 4.6.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Admin vs Super-Admin Capabilities in Multisite’ is closed to new replies.