Support » Plugin: Nonprofit Board Management » Admin users showing up as board members

  • Resolved jeff501

    (@jeff501)


    Since the last update it seems that all admin level users show up as board members, We have tried unchecking the “Serving on Board” option but the save is not changed and box rechecks. We got around this by creating a “fake” admin level role, and assigning that to users. However, the “super admin” user can’t have their role switched, so they show up on the board listing.

    Is this intentional and is there a way around it?

    Thank you.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jonathan Goldford

    (@jg-visual)

    Thanks for reaching out @jeff501 and I’m sorry you’re running into issues. We didn’t make any changes in our last update to how admin users are treated on the board. It sounds like something else is going on here.

    Would you mind answering a few questions:

    • Just to confirm, are you using WordPress multisite or a single-site instance of WordPress? It sounds like you’re on multisite, but I wanted to be sure.
    • Do you have any role management plugins on the site and if so, have you modified the “serve_on_board” capability? That capability dictates which users serve on the board. If that has been changed from the default setup, then it could cause issues.
    • Have you tested this on a default WordPress installation to make sure there is no custom coding interfering with the plugin?

    We’re out of the office for the holidays tomorrow and Friday, but will be back next week. Once we have a little more information we can hopefully help you figure out what’s going on.

    Thread Starter jeff501

    (@jeff501)

    Thanks for the response.

    This is a single site installation.

    We have User Role Editor on the site, but have not modified any setting related to the plugin.

    I have not tested on a clean install, but will give that a try next and let you know the results.

    Happy Holidays.

    Plugin Author Jonathan Goldford

    (@jg-visual)

    That sounds great. Let me know how it goes and we’ll discuss next steps.

    Plugin Author Jonathan Goldford

    (@jg-visual)

    Since we haven’t heard from you in a while we’re going to mark this as resolved. Don’t hesitate to reach out if any other questions come up.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.