Support » Themes and Templates » admin theme selector bug – further details – themes.php

  • This message is related to the other post about the problem I am having with the theme selector page.

    Here is the relevant portion of the themes.php file which is generating the above markup, if someone would like to see the entire themes.php file please let me know. Thanks in advance. Paul

    <h2><?php _e('Available Themes'); ?></h2>
    
    	<?php if ( 1 < count($themes) ) { ?>
        <?php
    		$style = '';
    
    		$theme_names = array_keys($themes);
    		natcasesort($theme_names);
    
    		foreach ($theme_names as $theme_name) {
    			if ( $theme_name == $ct->name )
    				continue;
    					$template = $themes[$theme_name]['Template'];
    					$stylesheet = $themes[$theme_name]['Stylesheet'];
    					$title = $themes[$theme_name]['Title'];
    					$version = $themes[$theme_name]['Version'];
    					$description = $themes[$theme_name]['Description'];
    					$author = $themes[$theme_name]['Author'];
    					$screenshot = $themes[$theme_name]['Screenshot'];
    					$stylesheet_dir = $themes[$theme_name]['Stylesheet Dir'];
    					$tags = $themes[$theme_name]['Tags'];
    					$activate_link = wp_nonce_url("themes.php?action=activate&amp;template=".urlencode($template)."&amp;stylesheet=".urlencode($stylesheet), 'switch-theme_' . $template);
    	?>
        <div class="available-theme">
            <h3><a href="<?php echo $activate_link; ?>"><?php echo $title; ?></a></h3>
    
    		<a href="<?php echo $activate_link; ?>" class="screenshot"><?php if ( $screenshot ) : ?><img src="<?php echo get_option('siteurl') . '/' . $stylesheet_dir . '/' . $screenshot; ?>" alt="" /><?php endif; ?></a>
            <p><?php echo $description; ?></p>
    
    		<?php if ( $tags ) : ?>
            <p>
                <?php _e('Tags:'); ?>
                <?php echo join(', ', $tags); ?></p>
            <?php endif; ?>
        </div>
        <?php } // end foreach theme_names ?>
        <?php } ?>
  • The topic ‘admin theme selector bug – further details – themes.php’ is closed to new replies.