Support » Alpha/Beta/RC » admin submenus not appearing on hover – but only on dashboard page, on my server

  • I’m seeing a weird issue that I can duplicate all day on my own server, but never on other servers – so I’m not sure if anyone’s going to be able to help, but I’d still like to figure it out, in the event anyone else needs to use a site hosted on my server. On the Dashboard home page (and only on this page!), submenus are not appearing when hovering with a mouse over (or touching on a touch screen) the top-level admin menu items.

    My site(s) are hosted with anhosting. If I install WordPress 3.5-RC1 – through any method I can think of (downloading RC1 directly, installing 3.4.2 and upgrading through the WordPress Beta Tester plugin, downloading the latest nightly, etc.) – and then visit the Dashboard home page (/wp-admin/ or /wp-admin/index.php), in any browser – and then hover over top-level admin menu items (Posts, Media, Pages, etc.) – their respective submenus do not appear.

    If I visit any other page in /wp-admin/ on my server, the submenus appear as expected.

    If I install via any of these methods on another server (I’ve tried servers hosted with GoDaddy and Hostmonster so far), the submenus appear as expected.

    Using Web Inspector I can tell that, when hovered over, a top-level admin menu item should receive the class ‘opensub’, which then repositions its submenu so that it’s visible. There was a lot of good work done on this functionality recently to make the admin menu & submenus behave more consistently across various mobile browsers (see changeset #22636). I can tell that, when 3.5-RC1 is installed on my server and I’m on the Dashboard home page, that class simply isn’t being added when I hover over a top-level menu item (or touch it on a mobile touchscreen). No errors are being thrown in Web Inspector, the class just simply isn’t added so the submenu doesn’t appear.

    Is anyone else out there encountering this issue? I can’t think of how anhosting’s server configuration could be at fault, as this seems to be a JS issue, but if so I’d love to know what to look for. I’d be happy to give someone access to an installation on my server so you can see for yourself.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Try putting this in your wp-config.php

    define('SCRIPT_DEBUG', true);

    Adding either of the following:

    define('SCRIPT_DEBUG', true);


    define('CONCATENATE_SCRIPTS', false);

    yields the desired result. Thanks for the suggestion, Ipstenu! it’s my understanding that setting the ‘script_debug’ constant causes WP to use the non-minified scripts and styles – is that right?

    I’m still not sure how this might only cause problems on my server but not on others… any ideas?

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Yep, Script Debug turns off minification.

    I’d put dollar down on weird caching with your server.

    I still want to figure this out 100% for my own sake, but it does seem to be a problem with my server, or host, so I’ll mark it as resolved. Thanks again for pointing me in the right direction, Ipstenu.

    I’m having the same problem, and define(‘SCRIPT_DEBUG’, true); solves it, but only as long as it’s active.

    Hi, I’m on a bluehost shared account, and this occurs on some sites on our account, but not others. Not sure if this helps track down the problem or not. The fix above resolves the issue on the individual site I’m seeing the issue on.

    Same issue, defining define(‘SCRIPT_DEBUG’, true) has a temporary effect – can it be changed on the next word-press version?

    @ipstenu you were right about this. It was a weird cache issue for me. I use Cloudflare as my CDN and “oh crap” backup to prevent downtime. Purging my cache in my Cloudflare settings corrected that (and quite a few other issues like basically any button on Ultimate TinyMCE and setting categories and tags).


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘admin submenus not appearing on hover – but only on dashboard page, on my server’ is closed to new replies.