Admin slowness and other issues after 3.7.1 update (24 posts)

  1. tcwaters
    Posted 2 years ago #

    Did the 3.7.1 update on a Multisite install and now have two issues. Not sure how to resolve. This may be specific to our configuration. We have a load-balanced set up.

    After the update, I got this error:

    Fatal error: Call to undefined function wp_using_ext_object_cache() in D:\Sites\pages-pharmacy\wp-includes\option.php on line 170

    I then replaced the /wp-admin/ folder with a copy of the folder PRIOR to the update.

    The site would then open and run, but trying to open anything in the /wp-admin/ for any of the included sites takes 3-5 seconds. For example, get into a site admin, click on "all posts" wait 5 sec, ad screen refreshes. Click on "add new" wait 5 sec, for the screen to refresh.

    The slowness ONLY happens for the /wp-admin/ stuff. The end user experience is not affected at all.

    At the top of every admin page, I see this:
    Thank you for Updating! Please visit the Upgrade Network page to update all your sites.

    If I click the link for Upgrade Network, it tells me the Network is upgraded, but the message remains at the top of all admin pages.

    All help appreciated. THX

  2. caesss
    Posted 2 years ago #

    +1 same issue. All my sites that I've updated to 3.7.1 become very slow on admin, sometimes even lose DB connection. this only happens in 3.7.1 the ones I have in 3.6 appear fine.

  3. Interesting. Mine is running noticeably faster.

    If I click the link for Upgrade Network, it tells me the Network is upgraded, but the message remains at the top of all admin pages.

    THAT is interesting.

    Reinstall 3.7.1 manually. Try again.

  4. Hans
    Posted 2 years ago #

    I upgraded via Installatron and now the whole install of WordPress is very slow. Not just the admin also performance on blog dropped.

    I also have the message on top of my admin screen to update:

    An automated WordPress update has failed to complete - please attempt the update again now.

    But it is 3.71. now.....

    How to solve bad performance?

  5. tcwaters
    Posted 2 years ago #

    The web server admin tells me he is having some other issues with Word Press for other users, and so feels there is something not properly set up for our servers. Our plan is to test doing the update on a stage server so we can monitor the server during the update and see what we learn about this as well as his other issues.

    I'll report back on the findings.

  6. df03472
    Posted 2 years ago #

    See a major slowdown while using Admin like editing a page. I am using WP 3.7.1, Safari 7.0 and just migrated to Mac OSX 10.9. Many changes all at once.

    In WP trying to edit a page, I get the cursor I beam. When I click on a place I want to add more text or make a change, nothing happens. I get the spinning beach ball of death, and have to wait a while so I can make a change. After several minutes I can edit, make my changes, but must wait a long time for the actual save.

    I have tried different combinations of Safari, WP, Mac OSX but the one item that always comes up SLOW is with OSX 10.9 (Mavericks) *BUT* if I use Chrome, with OSX 10.9 it edits fine. Feel like I'm in the twilight zone.

    BTW, tried cleaning cache in Safari, removing Glims, and extensions.

    Any one else experiencing this problem.

  7. I did some stress testing. Safari on Mavericks is like a step BACK in usability for more than just WP :/

    I think they changed how they cache content.

  8. CyberMama
    Posted 2 years ago #

    Ditto the above. Since the update to WP 3.7.1 all my sites are sooooooo slllloooooow, on various hosting platforms (mainly the shared ones though). It's actually painful. Trying to edit/admin the sites is chronic.

    I've tried various browsers and didn't update to Mavericks as had heard so much bad stuff about it.

    Can anyone help?

  9. esmi
    Forum Moderator
    Posted 2 years ago #

    @CyberMama: If you require assistance then, as per the Forum Welcome, please post your own topic.

  10. CyberMama
    Posted 2 years ago #

    Ok - will do :)

  11. curtis.mack
    Posted 2 years ago #

    I had this problem and it turned out to be an internal host name resolution problem. With the way I have multi-sites set up, each site has an alias host name that is only used internally. For some reason one of the resent updates caused my system to expect to be able to resolve this address externally. When I added that host name to the hosts file, everything cleared right up.

  12. sudwebdesign
    Posted 2 years ago #

    +1 df03472

    Yes, I've started seeing this problem trying to edit a post/page on Mac Safari & Firefox but Windows fine!

    Did you find a solution?

    I've cleared cache, refreshed, uninstalled firefox and resinstalled ....

  13. caesss
    Posted 2 years ago #

    Me too still no fix

  14. sudwebdesign
    Posted 2 years ago #

    Post/Page now working in all browsers on OSX after updating all the plugins but cannot edit Products in WP-Ecommerce on OSX or Windows.

    I can't update WPEC as I've hacked the core!

    I've noticed that when editing post/pages/wpec products etc there is AJAX traffic with a rotating GIF where Admin is getting a new lock every few seconds ...

  15. I can't update WPEC as I've hacked the core!

    And this is why we tell you not to.

    You need to sit down and compare your hacked version with the real version, marry as many of the diffs as possible, and hope for the best.

  16. sudwebdesign
    Posted 2 years ago #

    Thanks Mika,

    As a developer I'm aware of that and took the decision to overcome some weaknesses and bugs in WPEC about 3 years ago. I tend to upgrade WPEC about once a year, diff-ing the core.

    But there is no disputing that there are some incompatibilities with 3.7.1 that don't seem to have been documented properly.

    I've never seen an upgrade screw up admin so extensively, that without hacking the urls, i couldn't even have updated the plugins!

    Had I been aware of these I wouldn't have updated.

    So, i'll need to roll back to 3.7.0 and, as you say, diff the WPEC core sometime.

  17. As a developer, then, you understand that when there is an upgrade you should test it before applying it to a production site where you KNOW you've edited a pugin's core files. I'm not trying to be smarmy though I know plain text can come off that way, and this is really a reminder for the hundreds of NON Devs who may stumble across this thread. Don't edit core files of ANYTHING unless you know what you're doing. And even then, you probably shouldn't.

    Your specific issue is related to, but not the same, as tcwaters. Sadly, simply because you know you edited files directly, you would be better served in your own post where you can explain things without detracting from his issues. Similar, but not 100% the same, issues get their own threads here :) It makes it easier for us to help the OP.

    For most of this, I would do a manual-reinstall of WP's core files. It won't hurt you, and it may be that you have a file that didn't get updated right. Remember, these are FILES. There will never be a case where 100% of the time the get upgraded 100% without error. It's just a mathematical impossibility :)

    For the others, turn off your plugins. I know. But the point here is that it may not be CORE that's the problem, but a plugin doing_it_wrong() as we say.

  18. CyberMama
    Posted 2 years ago #

    Curtis.mack - please excuse my ignorance but I don't quite understand:

    " it turned out to be an internal host name resolution problem " - can you possibly expand and detail the exact steps you took? Thanks :)

    Mine is not a multi-site installation in this case.

    The host company are blaming WooCommerce for using too many resources and slowing the site down. This is odd as it was working fine…

    I've stripped it right back plug-in wise and everything is up to date. I haven't played around with any of the core files….

  19. CyberMama - Please make your own topic. Preferably outside of the Multisite section.

  20. sudwebdesign
    Posted 2 years ago #

    Hello Mika

    Thanks for your feedback and yes, I know you should test on Dev first. Easy to get lazy, especially with a point release. Won't be doing that again!!!

    For the record, I fresh installed 3.7.1 and then the latest WPEC and all ran OK. It appears that it was the WPEC theme that I was using, which has not yet been updated that was at fault.
    BTW it was the theme that I had changed and not WPEC core.

    I've test a new WPEC theme and that seems to be the answer.

    I still get a nasty whirly Gif when editing posts though. As I said above, something AJAXy going on behind the scenes and very distracting.

  21. Make sure your server cache got flushed. I had a moment where Memcached decided I really wanted to cache everything, and had to restart httpd to clean it out.

  22. dhirajrode
    Posted 2 years ago #

    wp-ecommerce plugin not working after upgrading to 3.7.1 .

    It shows blank page when I click on product page

  23. WPyogi
    Forum Moderator
    Posted 2 years ago #

    @dhirajrode - you need to start your own thread in the plugin's own forum here:


    See the sticky post at the top first.

    Your issue is not related to this thread at all.

  24. df03472
    Posted 2 years ago #

    This problem, for me, went away with the system update of Mac OS 10.9.1

Topic Closed

This topic has been closed to new replies.

About this Topic