admin site works fine, actual site is totally blank (10 posts)

  1. alexandtheweb
    Posted 4 years ago #

    Hello folks,

    I've just done a completely fresh WP3 install for a client. The host is LCN.com.

    The installation went fine, the admin site worked fine. I was able to log in, add and save new posts, etc. However, the actual site and all individual posts appear blank! No source code, no error messages.

    Here's what I tried:
    - Changing the permalinks structure to various formats
    - Reinstalling the whole lot from scratch
    - Adding PHP error reporting to my htaccess (when I do that, I simply get an Erro 500 page)
    - Checking permissions on my WordPress folders (they're set to at least 755)

    Any ideas? Please help!!!

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems?

    - resetting the plugins folder by FTP or PhpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    - increasing the memory available to PHP?

  3. alexandtheweb
    Posted 4 years ago #

    Hi esmi,

    Thanks very much for your reply.

    However, it's a totally clean install. No plugins are active, only Akismet and Hello Dolly are installed and they're inactive. I did try reuploading the entire installation from a clean WP download.

    I did try bumping up the PHP memory via htaccess but that didn't work either :-(


  4. Zulfikar Nore
    Posted 4 years ago #

    There are various reasons why this would happen on a fresh install.
    An incompatible theme or plugin - if you have gone as far as changing these from the default.

    Try running your site with default settings - ie. theme and permalinks (be sure to delete or rename the htaccess when you changed to default permalinks)

    Another posible cause could be an incomplete or bad upload of the wp-includes - you may want to completely delete and re-apload it again and see how that goes.


  5. esmi
    Forum Moderator
    Posted 4 years ago #

    Do you happen to know how much memory you do have allocated?

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    @ZGani: I think all of those points - although good advice - have been covered already.

  7. alexandtheweb
    Posted 4 years ago #

    Hi esmi - Nope, don't know how much memory I have allocated. I have emailed the host to find out, but no answer yet.

    Hi Zulf - No changes to the default I'm afraid. Everything is definitely uploaded as well, just checked again.


    Thanks again, guys.


  8. esmi
    Forum Moderator
    Posted 4 years ago #

    You should be able to run a simple install on 32M. Any lower and you're probably going to hit trouble. Additionally, not all hosts allow you to change the memory allocation via .htaccess or php.ini. Perhaps this is one of them (as well as being mean with memory)?

  9. alexandtheweb
    Posted 4 years ago #

    I'm hoping that's not the case - especially since they happily give you instructions on their blog on how to install WordPress, lol:


  10. Ricky_LCN.com
    Posted 4 years ago #

    Hi Alex, I can confirm LCN fully supports WordPress, many of our customers use it as well as myself.

    I guess you might have solved this problem since its been a week or so, but if you have any other questions or queries please get in touch at http://www.lcn.com/contact_us , phone or mail and ask for myself.

    Many Thanks
    Ricky, LCN.com

Topic Closed

This topic has been closed to new replies.

About this Topic