• Resolved gresakg

    (@gresakg)


    I have noticed that the plugin loads a lot of scripts, namely many wordpress scripts intended to be used for admin panel only. Among others are
    thickbox.min.js, shortcode.min.js, media-upload.min.js, backbone.min.js, plupload, sortable.min.js

    I am sure all this scripts are not needed on the frontend unless something shady is going on. On the other hand, the customizer might need them. You should check of you are in theme customizer context before loading these scripts.

    Please update this as it is a performance and possibly a security issue.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Organic Themes

    (@organicthemes)

    Hi @gresakg,

    Thanks for spotting this bug. That was a tricky issue to track down. However, it appears those scripts were being loaded by some of the widgets that had some unnecessary ‘media-upload’ and ‘media-views’ dependencies while enqueuing other necessary scripts.

    Anyway, I’ll be pushing a fix with the next plugin update that will resolve this issue.

    Thanks!

    David

    Plugin Author Organic Themes

    (@organicthemes)

    Hi @gresakg,

    I pushed an update to the plugin to resolve the issue. I’m going to mark this issue as resolved.

    Thanks!

    Thanks a lot to you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Admin scripts on frontend’ is closed to new replies.