Support » Plugins and Hacks » WP eCommerce » Admin reports missing and I lost the state info in the automatic email?

Admin reports missing and I lost the state info in the automatic email?

  • Store URL: thehappyhelmet.com
    WordPress version: 3.9.1
    WP e-Commerce version:
    Gold Cart version: n/a
    Theme: Mazine

    I did this: Upgraded WordPress and plugins after php upgrade on my server.

    I expected WP e-Commerce to do this: Send me admin reports as it did previously

    Instead it did this: Sent me admin reports without the US state. And in the admin tab in the Store, there isn’t an admin reports section anymore. Why does all the info except the state get sent in the admin email? I just need those two little letters (i.e. state) to come through.

    Thanks for your help!


Viewing 5 replies - 1 through 5 (of 5 total)
  • Really need help with this. The admin report email still doesn’t have US state and now a customer said that she wasn’t allowed by the checkout form to select a state from the dropdown, that she’d select and then click next and the form would make her select the state again and not advance to payment.

    Any suggestions?

    When was the last time you compared your theme’s checkout page to the default WP-eCommerce theme file? Maybe there is a difference that would reveal the issue.

    – jeff

    Hmmmm… Found the theme check out page and here’s the code pasted below. I went into the WPSC plugin files to compare but can’t seem to find the right checkout page to compare the theme to.

    Any help is much appreciated!

    <?php /* Template Name: Store Page Checkout */ ?>
    <?php get_header(); ?>
    <div class="backgroundbox">
    <div class="contentbox">
    <section id="content">
    	<div class="container_12">
    		<?php if ( ! dynamic_sidebar( 'Alert' ) ) : ?>
    			<!--Wigitized 'Alert' for the home page -->
    		<?php endif ?>
    	<?php if ( have_posts() ) while ( have_posts() ) : the_post(); ?>
    		<div class="grid_12 checkout">
    		<?php the_content(); ?>
    	<?php endwhile; ?>
    <?php get_footer(); ?>

    Shopping cart is not working for 3/4 of my customers. (They enter a state, form doesn’t allow them to advance, and gives them “enter a state” error message.) Losing money every day that this issue persists. I need a fix on this ASAP.

    Any help is much appreciated!

    Plugin Author Mihai


    @captainp go in the Checkout field settings and move the Country field above the State field in the billing section.
    That should resolve the select state issue

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Admin reports missing and I lost the state info in the automatic email?’ is closed to new replies.
Skip to toolbar