Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Admin redirect bug after activating of plugin

  • I have a strange failure on one of my sites. From time to time, URL’s in admin menu changing self on the go like “mysite.com/wp-admin/options.php” => “mysite.com//options.php”. I was checked plugins and after deactivating on Nextgen Gallery plugin this problem is gone. If NGG is activated, I cant save any post on my site admin. After saving url of post editing page instead of mysite.com/wp-admin/post.php?post=2897&action=edit changing to mysite.com//

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Imagely

    (@imagely)

    @viter-z-bayraku – Have you tried deactivating all of your plugins, clearing your browser cache (and site caches if you are using a caching plugin), then reactivating the NextGEN plugin?

    If this fixes the problem then it was likely one of the deactivated plugins that was causing an issue. Now, retrace your steps activating each plugin and re-checking to see if the problem returns. If it does then that last activated plugin was probably the one. Keep reactivating and in most cases it is also best to keep checking after each plugin, sometimes there may be more than one plugin on a site that will create an issue. If you do find one (or more) plugins causing this problem we would greatly appreciate your feedback on them so the developers may address them as soon as they can.

    Also to note, in rare cases it may be the theme itself that is causing a conflict so while you have just the NextGEN plugin activated you might consider temporarily switching to one of the default WordPress Twenty series themes and see if this corrects the issue as well.

    If the problem still persists after all of this we would still want to know, even more so, as we will still want to sort out the issue and may need additional details.

    Thanks!

    – Cais.

    Hello, @imagely. My problem still exists. And I found a javascript plugin that creates this problem. it is nextgen-gallery/products/photocrati_nextgen/modules/frame_communication/static/frame_event_publisher.min.js file.
    Part of code with this plugin and with code added bellow is exists inside admin panel:

    <script type='text/javascript'>
    /* <![CDATA[ */
    var frame_event_publisher_domain = ["mydomain.name"];
    /* ]]> */
    </script>

    And this plugin every time trying to change URL of links and urls inside admin panel.
    And as result, the latest version of your gallery still have problem with redirection to main domain instead of wp-admin part of site.

    @imagery, after disabling (commenting) module ‘photocrati-frame_communication’ inside product.photocrati_nextgen.php file problem is fixed. Please check this module, please.

    @imagery, sorry bug with NGG still exists. After editins some post and saving it page is redirecting and after this all links in menu loosing ‘wp-admin’ part and displaying like https://mysite.com//plugins.php .. URL in browser address bar changing to https://mysite.com// Seems it is problem with some ajax or javascripts functions of NGG gallery… After deactivating of NGG again all is working fine…

    Plugin Author Imagely

    (@imagely)

    @viter-z-bayraku – Just to confirm, using a WordPress Twenty series theme and only having NextGEN Gallery active on your site this problem persists?

    – Cais.

    @imagely, yes!

    Plugin Author Imagely

    (@imagely)

    @viter-z-bayraku – Please send us a Bug Report (https://imagely.com/report-bug/ … please reference this topic) so we can get a better look under the page at your site.

    Please include as many details as you can about your site and the issue at hand so we can move on this as fast as possible.

    Thanks!

    – Cais.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Admin redirect bug after activating of plugin’ is closed to new replies.