Admin problems after moving wordpress (6 posts)

  1. svenjick
    Posted 8 years ago #


    I just moved my wordpress from one place to another. I followed the steps in the Advanced Topics of the documentation on wordpress.org. The move was successful because the website displays properly, but unsuccessul in the sense that I can't log in to the wp-admin anymore. I get the following error message:

    You do not have sufficient permissions to access this page.

    This is strange as I previously had administrator rights. I tried creating a new user but the problem remains. I have found a few unofficial posts on the same error, but in only mildly similar cases, which I only half trust to try out. Can anybody help me, or guide me to a place where I might find ideas / help on the topic?



  2. svenjick
    Posted 8 years ago #

    OK, I've solved my problem - but don't ask me to explain the logic / thinking, as I myself don't understand what I have changed.

    This is how I proceeded. Inspired by http://beconfused.com/blog/2007/08/28/how-to-solve-you-do-not-have-sufficient-permissions-to-access-this-page-in-wordpress/ but reticent to write sql queries, I looked around for similar things in my db. I assumed that my problem was the same since I changed the wp_ prefix when moving my site to wp08_ . (it must be said that this reference article concerns earlier version of WordPress, not 2.5.1). So what did I do? I did 2 main things:

    1. In my table, wp08_usermeta, I changed all occurrences of wp_capabilities, wp_user_level, and wp_autosave_draft_ids to wp08_capabilities, wp08_user_level and wp08_autosave_draft_ids
    2. Then in table wp08_options I changed wp_user_roles to wp08_user_roles

    This, for reasons that I don't fully understand, resolved my problem. Can anybody explain this, and could this error be taken into account for future WordPress releases?

    Kindly, Svenjick

  3. skepchick
    Posted 8 years ago #

    Hi, I'm facing the same problem thanks to adding a 2nd blog on my site and changing the wp_ prefix. I wanted the user tables to be shared, which it appears they are (yay) but now my permissions are screwy and I can't access the admin panel.

    I'd like to do the fix above, but I'm baffled as to where to find the usermeta, user_roles, user_level etc. lines to adjust them to the new prefix. Can anyone help a n00b?


  4. skepchick
    Posted 8 years ago #

    Okay, update, I've figured out to use phpmyadmin to see the databases and make changes, but it appears as though when I set the new prefix for the new blog, it automatically put the correct prefix before capabilities, user_level, etc. But, I still get a permissions error when trying to access the new blog's admin panel. :( Help?

  5. lambs
    Posted 7 years ago #

    I know its late reply but I tried everything, then went to phpmyadmin went to the wp_table then wp_user roles opened that up and compared it with my other working blogs found a difference changed it and it worked!!!! ok in the text on the second line it should be a:53: INSTEAS of a:51: simple now everything works!!!!

  6. jamesbloor
    Posted 7 years ago #

    Thanks svenjick - that worked for me!

Topic Closed

This topic has been closed to new replies.

About this Topic