Support » Fixing WordPress » Admin Post Submit For Review

  • Resolved georgearthur


    My blog is

    I am admin no other users.

    Today my posts are not viewable and when I try to write a new post, the only option is submit for review. Posts are still there as shows count in categories. Reinstalled WP 3.0.1 and theme to no avail. No problems before today.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator James Huff


    It sounds like your account may have lost admin privileges for some reason.

    Access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to a:1:{s:13:"administrator";b:1;}

    Thank you. I didn’t know about accessing my database via phpMyAdmin and without your help I would still be looking for a solution. Site is up again!

    Moderator James Huff


    You’re welcome!

    Hi James,

    I’ve a similar problem, which I noticed today. I can see all the older posts. Can edit them too. However, when I want to add a new post or page, I only get the “Submit for Review” option. And when I “Submit for Review” I can’t see it anywhere so that I can approve. I’m also the main admin. Facing the same problem with other user accounts.

    I used the following command to modify the the table:

    update wp_usermeta set meta_value='a:1:{s:13:"administrator";b:1;}' where umeta_id=12 AND user_id=1 AND meta_key='wp_capabilities';

    Now, eventhough the wp_capabilities is updated, I’m continuing to face the same issue.

    Do you think I’m missing something?

    I have the identical issue on a site.. I’m main admin, checked the tables all is good on capabilites.. I have several other WP sites on this server all are fine.. just this one which only has submit for review and no where to review it!


    I am also having the same issue on a site. I have several other WP sites that are fine and it’s just this one which only has submit for review and no where to review it! I’ve have also noticed that the option to ‘Use as Post Thumbnail’ has disappeared!

    The site in question has only just recently relaunched and as a result of the relaunch traffic to the site has been high and it has exceeded its bandwidth allowance. Is there anyway this could be effecting WP? I am still able to access the site and login to WordPress I just can not post anything.

    Any help would be greatly appreciated.

    This has happened to me too.

    I checked the user meta and it is correctly set to a:1:{s:13:”administrator”;b:1;}

    Please can someone help?

    I wanted to chime in with a “me too” post. What I’ve tried so far (with no success):
    – Modification of the user meta to a:1:{….
    – Replacement of wp-includes/wp-admin
    – Deactivation of all plugins
    – Repair of the database itself
    – Creation of new admin user, deletion of previous admin users, and then recreation

    None of these attempts corrected the problem. For some reason, I’m not sure why, the site just began showing ALL users, regardless of assigned permissions a “Submit for Review” button rather than “Publish”.

    An attempt to save a page/post with “Submit for Review” results in it not actually getting written to the database – so the content is essentially lost.

    Also, though there are already existing posts in the wp-posts table, if you view “Posts” in the admin, it will tell you “No Posts Found”.

    I am just about to completely destroy the site and try to restore from backup, as I’m seemingly out of other options – but given that I’ve no idea what caused this problem, nor how to prevent it again, I’m obviously not thrilled about this proposed solution (nor are my users).

    I’m having the same problem. Tried all of the same fixes. Is anyone else hosted by godaddy? Is there an issue with that? I tried their support and they weren’t helpful with anything related to wordpress.

    I’ve tried to add a new admin and it won’t show up in WP 3.0.1. It is in the wp_user database table, though.
    I’ve tried uploading images in Pages, Posts, and through the Media menu and they won’t show up. They are in the correct directory when I ftp to it though.

    This site was recently upgraded from 2.6.2 to 3.0.1. When I back it down to 2.9.2 the “submit for review” button turns back to the “publish” button.

    I also have wp-ecommerce installed and cannot add products or variations.

    Basically, all of the stuff that was entered at wp2.6.2 is still there and I can edit it, but I can not add anything new.

    any help would be much appreciated.

    Here is what worked for me:
    1. Setup new wordpress-Blog without configuring the database
    2. copy theme and plugin-folder from current wp-installation
    3. rename current database
    4. export data from current database and import into new database
    5. name new database as the previous database

    Hi tkrammer,

    Tks for your input.

    When you mentioned “Setup new wordpress-Blog without configuring the database”, do you mean to set up a new WP blog on a another domain?

    Pardon me for asking this, because I am a dummy when it comes to the database stuff.

    I SOLVED this when I check tables “wp_posts” etc… They “lose” AUTO_INCREMENT attribute for they primary keys.

    I installed new wordpress on some test subdomain, then I compare table structure with fresh installed tables and change primary keys to AUTO INCREMENT like in “fresh” installed tables

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Admin Post Submit For Review’ is closed to new replies.