Support » Fixing WordPress » Admin permissions keep changing

  • WordPress keeps changing my permissions, thereby blocking me, as admin from making any new changes or adding new posts. We’ve already reset permissions, which worked for only one day. Please help!

Viewing 13 replies - 1 through 13 (of 13 total)
  • What “permissions” are you talking about, exactly?

    Hi there, thanks for reply. I’m referring to just about all of them. For instance, if I need to add a new post or change a profile setting for a user or update the new WP database. It won’t let me do anything. And we reset it yesterday. It worked just fine, then reverted back to the same this morning.

    Okay, but I need more information on what you’re “resetting”.

    See, WordPress doesn’t have any sort of “permissions” like you’re describing, so I’m trying to figure out what exactly you’re doing that “fixes it”, even for a while.

    Ok, will try to explain best as I can. First, we deleted inactive plugins and deactivated the rest. That didn’t work. Then, we reset our settings with our host, Network Solutions. When that didn’t work, we asked one of their WordPress specialists to look into the problem and it seems that we were able to use the basic functions to update settings and add new posts. And they reset our WP password. That lasted one afternoon, since this morning we can’t make any changes.

    Hopefully, that’s a clearer explanation.

    Unfortunately, that doesn’t really tell me what they changed or what the underlying problem is.

    You may have to talk with them again, to find out what the issue is. It may be something database related where your changes aren’t being saved or something to that effect.

    You’re right, I should have stated the initial problem. The first issue was I couldn’t add new posts. I would add text and headline, then try to Save a Draft and it wouldn’t go through. Then I noticed that the Publish button was gone from the Publish box and my only option was “Submit for Review.”

    That’s when I checked my profile settings to make sure the administrator settings were in tact, and it wouldn’t let me make any updates to my profile. Then, I tried to update a Subscriber profile, it wouldn’t let me do that either.

    The “Submit for Review” message comes up when you’re logged in as a user with a Role that doesn’t have the “publish_posts” capability. The Author, Editor, and Administrator roles have this capability by default, so perhaps the user you’re logged in as only has a Contributor role?

    Roles and Capabilities can be modified, but not by a default WordPress install. You’d need a plugin to modify those, basically. So either you have customized Roles, or your user account is only a Contributor role. Do you have more than one user account on the system? Can you log in as an Administrator and see what the users are configured as?

    Good question: I only have one login – the one for administrator. So, that is the crux of the problem. The admin login all of a sudden changed. And now, I can’t add new posts or update settings, which means my login is functioning as a subscriber and I don’t understand why. That’s why I said earlier that my “admin permissions settings changed.”



    Forum Moderator

    Using Phpmyadmin (or another MySQL management tool), first backup your database. Then navigate to your wp_usermeta table and locate the meta_key called “wp_capabilities” for your user_id. Change the meta-value for this record to:


    Well, not sure if that will work, but am willing to try. Here’s what the technician from Network Solutions (our site host) said about the problem:

    “During the previous assistance, the primary cause of the site errors was crashed database tables. Repairing them through phpmyadmin should resolve them if they occur again. There is not a permanent fix as crashes are performance based. Likely the size of your database may be a contributing factor for this. It appears the database is getting rather large, The wp_options table is exceeding 300MB (and around 435,000 rows of data) due to what appears to be a order handling application is filling it up. If there is an option to remove old history through this plugin on your site, it may assist with this.”

    I seem to be having a similar problem in that I cannot seem to add any themes, widgets, etc.
    Under the ‘Appearance’ select item on the Dashboard, it appears that I should have a number of selections but I have only ‘Themes’ and ‘Editor’. In addition, it appears that I should have an “Install Theme” tab along with the “Manage Themes” tab, but that, too, is missing.
    I have but one user, admin, and the meta-value for it is (as indicated above) a:1:{s:13:”administrator”;s:1:”1″;}.
    Can you give me any reason as to why can I not install widgets, plugins, themes, whatever?
    I am running on a localhost using Wamp server.



    Forum Moderator

    @scott6840: It is impolite to interrupt another poster’s ongoing thread with a question of your own and it causes significant problems for the forum’s volunteers. Please post your own topic.

    @htimes_admin: What ecommerce plugin are you using?

    During the previous assistance, the primary cause of the site errors was crashed database tables.

    Ahh, yes, that would indeed do it.

    And while I agree with them that 300 MB in the options table is far too big, that size isn’t extreme and wouldn’t “crash” the table. So yes, go repair the tables using phpMyAdmin, and give them an optimize while you’re at it, and definitely figure out what is causing all those rows to be in the options table… but also ask them why they think 300 MB is too big for a database. I have database tables in the multi-gigabyte sizes that work fine, so their explanation seems a bit off.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Admin permissions keep changing’ is closed to new replies.