Ready to get started?Download WordPress


[resolved] Admin permission error after 3.0 upgrade (12 posts)

  1. aflavio
    Posted 4 years ago #

    Hello everybody!

    I've been working with WP quite a while and never had any "relevant" issue with it! :) But after upgrading 1 of my sites to wp3, I'm having this annoying "You don't have permission..." when trying to access the dashboard with the Admin user. The stranger thing is that just ONE of the FOUR sites isn't working.

    Searching over the web, I've found some suggestions on how to fix it (most of it to WPMU), but none of them worked at all.

    Somebody could please help me out with this?

  2. It's possible that your account may have lost admin privileges for some reason.

    Access your database via phpMyAdmin (most hosting providers offer this in their control panel), go to the wp_users table and find the row for your user_login . Note the ID of this row. Now, go to the wp_usermeta table and find the wp_capabilities row for your user_id . Set the value of this row to a:1:{s:13:"administrator";b:1;}

  3. aflavio
    Posted 4 years ago #

    Hi, macmanx! Thx for your help, but unfortunately I had already tried this before... The wp_capabilities row for the admin (1) user is set to a:1:{s:13:"administrator";b:1;}

    Anything else I could try? Here's how the wp_usermeta looks like:


  4. Try decativating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

  5. livresoft
    Posted 4 years ago #

    It happened to me yesterday, resolved deleting the files from my Language folder (im using pt_BR Wp 3.0) via ftp. So the system turn back to English and I was able to login then restore the language pack.
    Not sure if this is applicable to you but solved to me.

  6. aflavio
    Posted 4 years ago #

    Hi, livresoft!

    Worked for me too! Thank you so very much for your help! But I just can't believe that it was only a damn "corrupted language error", lol.

    Thanks also to macmanx for the first support, :)

  7. wenu
    Posted 4 years ago #

    I tried all that and my problem persists.
    All except the Language pack but I'm running neat Eng anyway.
    I managed to crash the site last night looking for ideas and reverted to a Restore point. We get desperate sometimes heh

  8. livresoft, thanks for sharing! I'll be sure to recommend it as a potential fix.

    aflavio, you're welcome! I'm glad you found a solution.

    wenu, there's a solution out there someone. We just haven't found it yet.

  9. jrmar
    Posted 4 years ago #

    I'm having similar problems, site is there but no edit and no dashboard. Only get " do not have permissions." I don't understand the "corrupted language error solution if site is only in English, but will try it, if it might apply.


  10. ketanco
    Posted 4 years ago #

    my database was already like in the solution described so it was no use. but when i deleted the language files (i was using turkish) the problem was solved. thanks everyone

  11. yalamber
    Posted 4 years ago #

    I had similar problem but with author, see following blog posts http://tutorial.wpexpo.com/2010/07/12/changes-in-wp_capabilities-meta-field-in-wordpress-3-0/ for details for solution

  12. DrLightman
    Posted 4 years ago #

    In my case I had to create manually this option because it was missing, I don't know if this solution could work for you:

    INSERT INTOwp_options(option_id,blog_id,option_name,option_value,autoload` )
    VALUES (
    NULL , '0', 'wp_user_roles', 'a:5:{s:13:"administrator";a:2:{s:4:"name";s:13:"Administrator";s:12:"capabilities";a:62:{s:13:"switch_themes";b:1;s:11:"edit_themes";b:1;s:16:"activate_plugins";b:1;s:12:"edit_plugins";b:1;s:10:"edit_users";b:1;s:10:"edit_files";b:1;s:14:"manage_options";b:1;s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:6:"import";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:8:"level_10";b:1;s:7:"level_9";b:1;s:7:"level_8";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;s:12:"delete_users";b:1;s:12:"create_users";b:1;s:17:"unfiltered_upload";b:1;s:14:"edit_dashboard";b:1;s:14:"update_plugins";b:1;s:14:"delete_plugins";b:1;s:15:"install_plugins";b:1;s:13:"update_themes";b:1;s:14:"install_themes";b:1;s:11:"update_core";b:1;s:10:"list_users";b:1;s:12:"remove_users";b:1;s:9:"add_users";b:1;s:13:"promote_users";b:1;s:18:"edit_theme_options";b:1;s:13:"delete_themes";b:1;s:6:"export";b:1;}}s:6:"editor";a:2:{s:4:"name";s:6:"Editor";s:12:"capabilities";a:34:{s:17:"moderate_comments";b:1;s:17:"manage_categories";b:1;s:12:"manage_links";b:1;s:12:"upload_files";b:1;s:15:"unfiltered_html";b:1;s:10:"edit_posts";b:1;s:17:"edit_others_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:10:"edit_pages";b:1;s:4:"read";b:1;s:7:"level_7";b:1;s:7:"level_6";b:1;s:7:"level_5";b:1;s:7:"level_4";b:1;s:7:"level_3";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:17:"edit_others_pages";b:1;s:20:"edit_published_pages";b:1;s:13:"publish_pages";b:1;s:12:"delete_pages";b:1;s:19:"delete_others_pages";b:1;s:22:"delete_published_pages";b:1;s:12:"delete_posts";b:1;s:19:"delete_others_posts";b:1;s:22:"delete_published_posts";b:1;s:20:"delete_private_posts";b:1;s:18:"edit_private_posts";b:1;s:18:"read_private_posts";b:1;s:20:"delete_private_pages";b:1;s:18:"edit_private_pages";b:1;s:18:"read_private_pages";b:1;}}s:6:"author";a:2:{s:4:"name";s:6:"Author";s:12:"capabilities";a:10:{s:12:"upload_files";b:1;s:10:"edit_posts";b:1;s:20:"edit_published_posts";b:1;s:13:"publish_posts";b:1;s:4:"read";b:1;s:7:"level_2";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;s:22:"delete_published_posts";b:1;}}s:11:"contributor";a:2:{s:4:"name";s:11:"Contributor";s:12:"capabilities";a:5:{s:10:"edit_posts";b:1;s:4:"read";b:1;s:7:"level_1";b:1;s:7:"level_0";b:1;s:12:"delete_posts";b:1;}}s:10:"subscriber";a:2:{s:4:"name";s:10:"Subscriber";s:12:"capabilities";a:2:{s:4:"read";b:1;s:7:"level_0";b:1;}}}', 'yes'

Topic Closed

This topic has been closed to new replies.

About this Topic