Support » Fixing WordPress » Admin Panels -> white screens of death!

  • I’ve mentioned this in another post…. but this is really causing me some headaches.

    I have tried all ‘troubleshooting 101’ steps, including trying to use a completely fresh install of both WP3 and WP2.9.2 with brand new SQL databases.
    I’ve tried it on the ‘default’ theme, the ‘twentyten’ theme and 2 different themes i made with artisteer.
    I’ve tried it with NO plugins, I’ve tried it with my plugins folder renamed, I’ve tried it with the plugins installed.
    I’ve tried repairing my SQL database.
    I’ve tried checking my wp_config.php for extra lines at the ends.
    I’ve tried uploading fresh wp-admin and wp-includes files to already installed WP3 and WP2.9.2.
    I’ve tried virtually every possible combination of the above, in every possible order.

    But STILL, several of the panels in my Administration area (specifically the Permalinks panel and the Upload new media panel, also the ‘networks’ panel if I try to activiate multisite) are showing up completely empty!
    (With a WP2.9.2 I get the text blurb at the top of the panels and then nothing.)

    This is really really really distressing! My server has PHP 5.3.2 and Apache 2.2.15 and MySQL 5.0.9-community. I have a custom PHP.ini file installed to allow me more php memory (but I have also tried without it).

    Can anyone help me???? Please??? I will love you forever if you do!

Viewing 14 replies - 1 through 14 (of 14 total)
  • I am thinking that you may be finding an error in the code, or your PHP.ini file has something like E_ALL set for your error_reporting.

    Check your php.ini file first. Try changing the error_reporting to be lower. You will need to restart your apache instance for this to take effect.

    If that does not solve the problem, I would start looking for error logs and see if you can find the specific error that is being thrown.

    I had to upload my own PHP.ini file that my hosting sent me… and how would one restart one’s apache instance on shared hosting? (I do not hold out much hope for getting them to do it, they’re absolutely useless… I contacted them about cancelling my account 2 days ago and they still haven’t got back to me!!!)

    Is there somewhere I can download a good PHP.ini file to use with WordPress and PHP 5? I’m looking through this one and I’m not sure it is all that good…

    Who are you hosting with currently?

    Typically on shared hosting they don’t take kindly to php.ini files because they want to control the experience. You probably would have to look in their KB to see how to get your instance restarted.

    I’m hosting with crazy domains in australia (stupid mistake….)

    But they are fine with custom php.ini files – they actually sent me one to try.
    I had a look inside and I’m not too sure it’s set up the best for wordpress though….

    Drop your PHP.ini file here:

    I would like to see what it has set and how.
    I am wondering if there is some sort of setting in there that is causing WP to completely fail…

    Possibly something as easy as turning short tags back on.

    Here’s the PHP.ini

    And this is just bizarre. I contacted my hosting about this problem, because it is definitely not a problem on my end. (I know, because another site I admin with WordPress is working fine).
    I thought, well maybe I’ll try attempting to set this site up just like the other one that works. So after copying my plugins folder and exporting the MySQL databases of the 4 WP installs I had (one on the main domain, three on subdomains) I installed WP 2.9.2 with the Fantastico in my cPanel, and set it up exactly like the other site I have.
    I took screenshots and sent them to my hosting.
    Error Screenshots
    The first shot is the Permalinks panel working on my other site (which is a completely different domain and hosting plan). The second shot is the permalinks panel straight after the install of 2.9.2 with fantastico, before I had even attempted to add any information like posts or pages. The third is the update to 3.0 screen (to prove to my host that this is not a memory issue). The fourth is the permalinks pane with the upgraded 3.0.
    (I tried all of that without even bothering to add the PHP.ini)

    After taking those shots, I imported the SQL file back into the new SQL database that had been created.

    NOW I am trying to access my site… but somehow, all of the code in all of the PHP files in my WordPress install have been completely erased! Like the files are all still there, but they are empty!

    It really does look like the issue with your admin pages is a javascript issue not allowing the page to load, without seeing it first hand using debugging tools it would be hard to tell you exactly what the issue is.

    I am not seeing anything in the PHP.ini file that made me even wonder, it is possible I missed something, but nothing is throwing and flags at me.

    Did you update the wp-config.php file to point to the new database when you were switching them around?

    Yes, I did update the WP config.

    I actually did it with brand new databases and installed as if it was a brand new site, and then just dropped all the database tables and imported my old ones.

    There must be a prob with the javascript code within the WP files somewhere, because other wise this would not be working on my other site…

    I would really like to help you further, but I will need to see the JS errors.

    You can try installing Firebug in Firefox and grabbing the errors and posting them here or you can feel free to find me through @wprelief (twitter). I would be happy to try to help you find the problem.


    The error that came up on the Firebug panel for the Permalinks page was
    ‘structure is null’
    line 119 in options-permalink.php
    the line is
    119 structure.onfocus = function () {document.getElementById('custom_selection').checked = 'checked'; }

    the ‘Upload Media’ panel got this

    I copied all of the errors from the permalinks panel to here

    Do you have a theme enabled?

    I did when I did that debugging, but I get the WSOD even with twentyten.

    did you solve it?? i have the same problem… my hosting provider had changed the server, with the new one, all my wordpress pages had the same problem… I cannot view the permalink admin panel apparently due a javascript error

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Admin Panels -> white screens of death!’ is closed to new replies.