Support » Fixing WordPress » admin panel edit box size

  • What *.php file do I need to edit in order to increase the size of the editing text box in the administration panel ?


Viewing 12 replies - 1 through 12 (of 12 total)
  • wp-admin/wp-admin.css:

    #content, #excerpt {
    margin-left: 1%;
    width: 97%;

    Thanks Kaf,

    What would I have to add to increase the height of the box so that I can see more of the text that I am editing.

    Do I just add:


    height: 500px;

    after the width: 97% ??

    Ah, I misunderstood the question. I’m not sure why but this is actually set from the database. You can access the setting through:


    Scroll down to default_post_edit_rows.

    I’m using 1.5 strayhorn.

    I don’t see “default_post_edit_rows” in the wp-admin/options.php file.

    When in the administration panel/write/post window – the source code for that page shows this:

    <fieldset id="postdiv">
    <legend><a href="" title="Help with post field">Post</a></legend>

    <div id="quicktags">
    <a href="" title="Help with quicktags">Quicktags</a>:
    <script src="quicktags.js" type="text/javascript"></script>
    <script type="text/javascript">edToolbar();</script>
    </div><div><textarea rows="9" cols="40" name="content" tabindex="4" id="content"></textarea></div>

    I suspect it’s just a matter of changing the rows= value. However, the above code appears in more than one *.php file in the wp-admin directory and I’m not sure which *.php file to edit to make the change in height that I’m looking for. (or do I have to make the changes across several *.php files)



    I seem to see this setting in 1.2, as well. Nevertheless, the only files you’d need to edit would be edit-form.php and edit-form-advanced.php.

    The code in those files is as follows:

    $rows = get_settings('default_post_edit_rows');
    if (($rows < 3) || ($rows > 100)) {
    $rows = 10;

    Is it just a matter of changing the value of 10 to something like 30?



    Tried changing the value to 30 and the height of the edit box did not change.

    $rows = get_settings("default_post_edit_rows");

    Shows that it’s getting the setting from the database, so try


    If not, just change the first $rows line, i.e.:

    $rows = get_settings("default_post_edit_rows");


    $rows = 30;


    This did not work for me:

    $rows = get_settings("default_post_edit_rows");


    $rows = 30;

    But this:


    worked just fine.

    Thanks a lot for your help.

    Note for future reference: I only just realized this can be set under Options > Writing, “Size of the writing box”.

    Really should learn about this thing called WordPress…

    What about changing the width? I’ve tried modifying the stylesheet and even changing the code that calls the textarea (increasing the cols up to 60).

    Anyone know? Its driving me up the wall!



Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘admin panel edit box size’ is closed to new replies.