Support » Plugin: Autoptimize » Admin menubar in page content

  • Resolved tabasko


    Hi there 🙂
    Thanks for your plugin I love it !
    Don’t want to share the url in this place as I won’t be able to edit in order to remove it in a few days. Sorry for that.

    Autoptimize worked like a charm since months, and now I had yesterday an issue with my admin meubar.
    Its content appear inside of the page (instead of the black top bar)

    If I disable Autoptimize this problem is solved but all my page layouts are broken (can’t guess why – I’m using backery editor)

    Searching in Autoptimize options, if I remove admin-bar.min.css from CSS exclusion list, than menubar is back (but with missing icons) if I also remove dashicons.min.css, then it’s OK.

    So I’m forced to remove from exclusion admin-bar.min.css, dashicons.min.css in order to fix. Is there any known reason around this ?

    Writing this message helped me in finding my answers 🙂

    To resume : not sure to understand/guess why it stopped to work as expect.
    Really worried by fact that if I disable Autoptimize page appearance modifed.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Optimizing Matters


    Seems like admin-bar.min.css/ dashicons.min.css weren’t loading when excluded for some reason, I suppose they were not found (404). This seems to be happening for other CSS-files as well, as witnessed by the fact your site breaks when you disable AO. When CSS-files are aggregated by AO they’re loaded from elsewhere (wp-content/cache/autoptimize) and that does work.

    Based on that (a) the files are there (as AO can aggregate them) but (b) the webserver can’t load them, so my money would be on the change in an .htaccess file somewhere?

    Thread Starter tabasko


    Will investigate on that way.
    Thanks for your fast and accurate answer.

    Plugin Author Optimizing Matters


    you’re welcome, feel free to leave a review of the plugin and support here! 🙂


Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.