Support » Fixing WordPress » Admin Menu Links Spontaneously Loading Incorrectly

  • Resolved Aaron_PN

    (@aaron_pn)


    For the life of me, I can’t figure out why the the JS is not loading the menu links correctly. If I disable javascript, the menu is fine. But when I enable javascript, this is what I see:

    http://s30.postimg.org/p9tbpxo5t/Capture.png

    I have tried disabling ALL plugins, I have tried changing themes, still not working right.

    Thanks for any help. 🙁

Viewing 12 replies - 1 through 12 (of 12 total)
  • Which browser are you using? Have you tried using a different one?

    I also recommend clearing cache, cookies and history within your browser and see if that fixes the problem.

    Let me know if you’re still experiencing this issue.

    This was strange, but the original bug happened on my work computer (my actions didn’t cause the bug, I know this because it was fine the night before, and then this happened suddenly when I logged in again during the day). When I got home and logged on, the bug was gone and I couldn’t replicate it.

    My work PC does filter certain websites from being accessible. I’m betting the filter caused whatever site the javascript was loading from to be blocked.

    I use Chrome at work and at home. I cleared the cache on both (ctrl + f5). Also use a cache killing plugin. Definitely not the cache.

    I guess I’ll just ignore it unless you have any other ideas?

    Hi,

    This is a known bug with Chrome 45+.

    We are tracking the issue here: https://core.trac.wordpress.org/ticket/33199

    Having the exact same issues. Would you recommend not using Chrome at the moment with WordPress then due to the issues?

    Not using Chrome, for now, is probably the most recommended method – or if you read over that linked ticket, there are a couple workarounds, although they’re a little more advanced and by no means permanent.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Chrome 45 has a rendering bug. There is a ticket open on Chrome’s bug tracker about this issue, hopefully they will fix it soon.

    In the meantime, here is a workaround to eliminate the issue in Chrome.

    – Go to chrome://flags/#disable-slimming-paint
    – Enable the “Disable slimming paint” option.
    – Ensure that the “Enable slimming paint” option below it is not turned on.
    – Relaunch Chrome.

    When you’re done, the final result should look like this:
    https://cloudup.com/cddYghY8fBd

    This will disable the problem code in Chrome and allow the menus to render normally.

    Thank you for the work around. Will this affect any other sites when I “disable”?

    it will fix it on all sites, as you made the change via your browser.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Will this affect any other sites when I “disable”?

    Sure. It will make them render correctly. 🙂

    Ah ok suddenly this is making sense, thanks.

    This may be unrelated, but could the same Chrome rendering bug also be causing this problem:

    https://wordpress.org/support/topic/bug-inappropriate-line-breaking?replies=7

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @aaron_pn Almost definitely unrelated. That is a long standing issue in Chromium, this is a relatively recent one, created about 2-4 months back.

    Ok thanks Sam! 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Admin Menu Links Spontaneously Loading Incorrectly’ is closed to new replies.