Support » Fixing WordPress » Admin login returns 404 not found

  • The site admin returns a 404 not found after attempting to log in. Also, all pages except for the home page have lost styling. This happened after one of our users fiddled with the settings and changed the permalinks. The person that setup the website did so under a folder named ‘site’, and that is where the original path was set for the permalinks. The url of the site is StepStonesforYouth.com.

    I am baffled, is there anyone out there who has any idea? I have tried deleting the .htaccess, changing its attributes, restoring wp-admin and wp-includes. None of this have achieved anything.

    I will really appreciate any help.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Moderator keesiemeijer

    (@keesiemeijer)

    Can you login here: http://www.stepstonesforyouth.com/site/wp-login.php
    if you can login change the permalink back.
    Did the user change the permalink or the site url?
    if you can login look under Settings > General and check if the WordPress address(URL) and the Site address (URL) are correct. Be very carefull to change them.

    also try:
    – switching to the default theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.

    Hi keesiemeijer, thank you so much for responding so promptly, I really appreciate it. When I login at http://www.stepstonesforyouth.com/site/wp-login.php, after entering the credentials, it redirects to http://www.stepstonesforyouth.com/wp-login.php, and displays a 404. The description that I got from the user, says that she went to ‘permalinks’ under ‘settings’ and changed the url from http://www.stepstonesforyouth.com/site to http://www.stepstonesforyouth.com.
    I don’t have access to any of the admin pages, that is why I cannot get in to reverse what was done.

    Moderator keesiemeijer

    (@keesiemeijer)

    You can only change permalinks like so ‘/%year%/%monthnum%/%postname%/’.

    Or did you have “site” in the permalink structure ‘/site/%postname%/’?
    In what directory are the wordpress files?

    The wordpress files are also under “site”

    Moderator keesiemeijer

    (@keesiemeijer)

    put this in your wp-config.php and see if that make’s a difference.

    define('WP_HOME','http://www.stepstonesforyouth.com/site');
    define('WP_SITEURL','http://www.stepstonesforyouth.com/site');

    Ok. I put it in at the end of wp-config.php. Now, when I go into the login page, it displays with the appropriate styling with the WordPress logo and all. I doesn’t allow me to log in though. It redirects to: http://www.stepstonesforyouth.com/site/wp-login.php?redirect_to=http%3A%2F%2Fwww.stepstonesforyouth.com%2Fsite%2Fwp-admin%2F&reauth=1
    Everything else remains the same.

    a) Make sure that the lines you added to wp-config.php occur above the /* That's all, stop editing! Happy blogging. */ line.
    b) Find the * Authentication Unique Keys and Salts. line in your wp-config.php and try following the directions there to replace your keys and salts.

    Thank you so much Curtiss! That worked well! I now have access to the WordPress dashboard and the entire site displays properly. Whew!

    There is one new issue, which I believe is still related to this whole mess,that I need to resolve: In the WordPress dasboard, when I go to the list of pages, all of the pages are properly listed there. But if I click on edit for any of them, I get nothing in the middle (where you would actually edit the page). The page attributes, on the right indicates: “Fatal error: Cannot instantiate non-existent class: walker_pagedropdown in /home/heather/public_html/site/wp-includes/post-template.php on line 903”
    Any ideas as to how to approach this?

    It sounds almost like the installation or an upgrade didn’t complete successfully. Try performing a manual upgrade to see if that fixes the issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Admin login returns 404 not found’ is closed to new replies.