Admin login redirect not working (14 posts)

  1. vjneal
    Posted 11 years ago #

    I previously had 1.2 installed without any issues.
    Decided to do a complete reinstall for 1.5. Deleted database and all WP folders.
    Installation works fine but when I try to login with the admin username and password it seems to accept the password but redirects right back to the login screen (no errors). WP installed without errors.
    This happens on all browsers (deleted cache, cookies etc).
    Checked database values for 'home' and 'siteurl' and they are both correct.
    Tried using the copy-paste method for wp-login.

    I was able to reinstall 1.2 and it worked just fine.

    Anyone have any ideas?

  2. Kafkaesqui

    Posted 11 years ago #

    Delete the cookie file(s) in your browser for your site. Then close the browser, restart it, and try to log in again.

  3. vinceh
    Posted 11 years ago #

    I'm suddenly having this problem as well with 1.2.

    Did you happen to notice the redirect goes to a repeating URL? "wp-login/wp-admin/wp-admin/wp-admin/wp-admin/"

  4. James Huff
    Support Team Rep.
    Posted 11 years ago #

    Vinceh, that's a security hole in v1.2.

    First, fix your siteurl and home values via phpmyadmin.

    Then, upgrade to WP v1.5.

  5. vinceh
    Posted 11 years ago #

  6. vinceh
    Posted 11 years ago #

    (my apologies to vjneal for this threadjacking)

  7. James Huff
    Support Team Rep.
    Posted 11 years ago #

    There's no real literature except a few scattered forum posts as this was kept below radar.

    What you'll have to do is follow the normal upgrade procedures to get from v1.2 to v1.5.

    BUT BEFORE RUNNING UPGRADE.PHP, fix your siteurl and home values via phpmyadmin.

    Then, run upgrade.php.

  8. bdjohns1
    Posted 11 years ago #

    Also, I ran into some 1.2 problems when I tried to upload the ZIP file and unzip it using CPanel's built in file manager. Something got messed up in there. Unzip the files locally, then mput* the whole enchilada over to your site.

  9. GeeBee
    Posted 11 years ago #

    I have the same problem and none of the above helps. New install of WP1.5 in a sub called 'blog'. The blog itself is there. Only wp-login.php redirects to the same page after entering the password.

  10. oriecat
    Posted 11 years ago #

    Are you sure the username and password are right? If the values aren't right it takes you back to the login page.

  11. GeeBee
    Posted 11 years ago #

    100 % sure. Also did cut & paste from the e-mail message with the password. Also asked for new password. Keeps redirecting... :(

  12. Ryan Boren
    WordPress Dev
    Posted 11 years ago #

    Using IIS? See this bug.

  13. weink
    Posted 11 years ago #

    I think I have found a workaround for this problem. I upgrade from 1.2.2 to 1.5, and no longer could load the login page. It has nothing to do with wrong user name or password.

    It seems that when I installed WP1.2.2 using cPanel through the sub-domain of "blog.weink.net", and this seems to be creating problems. I had to change the site URL to "weink.net/blog/" in order to load the admin login page.

    Now, the only way to change that address is through the admin login, so you really have to do it through your phpMyAdmin.

    Using phpMyAdmin"Databases", pick your WP_database
    Click the "browse" icon on the wp_options table
    Edit the "siteurl" to the driected url, i.e. if you have a domain "blog.weink.net" that redirect to "weink.net/blog", make sure to change it to the later url.

    I hope this works for you all.

  14. gvibe06
    Posted 10 years ago #

    (Re-Hi-Jacked my thread)

    OK ..

    Yes it was the siteurl and home. I set them to http:// in an attempt at having it just work from anywhere.

    I'm hosting this thing from home until I see if its going to go anywhere.

    Since I am work most of the day I would like to access my admin page from work (and also from home when I'm home) without having to constantly change the values of siteurl and home.

    With another website I used to own, the host server was always set up as localhost -- those were the settings used for both Url and mysql when I installed the nuke cms package I used then.


Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.