WordPress.org

Forums

Admin Login Keeps Redirecting (5 posts)

  1. dshafer
    Member
    Posted 4 years ago #

    I don't know if this is a WP config problem, a site-specific issue of some sort or a host-related problem, but it's driving me insane. I have searched the Web and this forum for an answer and can't find anything. It has cost me hours and hours of time. I hope someone can help me. Soon.

    I type into the browser or click a bookmarked link that says:

    http://www.sitename.org/wp-admin

    The browser replaces that line with:

    http://www.sitename.org/wp-login.php?redirect_to=http://sitename.org/wp-admin/&reauth=1

    Where is that redirect coming from? Why is it there? What can I do about it? The net effect is that I get the login screen back, password field empty, no error, no indication of a problem except I can't get at my Dashboard.

    This happens in all major browsers on my Mac.

    Thanks.

  2. bookchiq
    Member
    Posted 4 years ago #

    I ran into this problem on a client's blog (and she's using Windows while I use Mac, so that ruled out a few things right there). Tried tracing this in various ways and searching, and eventually found something useful in the Codex.

    My problem was exactly as described there: the database options for siteurl and home were wrong. Not sure whether this was the result of something my client did, a bug, solar flares, etc. but fixing those options (through phpMyAdmin) did the trick. Go figure.

  3. govpatel
    Member
    Posted 4 years ago #

    If you have conflicting plugin that will do same so try and deactivate by using ftp rename plugins folder to say plugins-hold create a new plugins folder then try loging in.

    If can log in then go back in ftp and delete blank plugins folder and rename the original back to plugins

    Now in admin activate one at time and see which is causing the problem.

  4. bookchiq
    Member
    Posted 4 years ago #

    @govpatel: that was one of the first things I tried. Didn't help me but it might be just the thing for someone else.

  5. govpatel
    Member
    Posted 4 years ago #

    I am sorry wrong place

    90% of time it theme or plugin conflict some times its .htaccess

Topic Closed

This topic has been closed to new replies.

About this Topic