Support » Fixing WordPress » Admin login error: Sorry, you are not allowed to access this page

Viewing 6 replies - 1 through 6 (of 6 total)
  • Check final one, as you are admin or not?

    Can you please share your screenshot for better understanding

    I now solved this in the following way:

    – I created a new admin user in the database
    – I logged in to admin no problem with the new username
    – To my surprise, I found that my original user’s role was showing as “None”. I am not sure how this happened, is it possible the recent update corrupted the database tables, or could it be a hack? Once I changed the role back to “admin”, I was able to log in as my old user, so I delete the new one which is no longer needed.

    I am still confused as to how this happened and I’d quite like to know for future reference, but I’m relieved to be back in.

    It’s not happened, please check if you install any admin role permission or user management plugins

    There is WordPress Access Control plugin installed, but I disabled all plugins when I was trying to regain access and it made no difference. Can a plugin permanently change a user’s role, even after the plugin itself is disabled?

    Sorry I don’t know about that plugin, may be that change the user role on database when it’s active state

    Hi Honggi,

    best to google it, plenty of step by step guides on how to do that:

    http://www.wpbeginner.com/wp-tutorials/how-to-add-an-admin-user-to-the-wordpress-database-via-mysql/

    You need to have access (and some basic understanding) of PhpMyadmin.

    Good luck!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Admin login error: Sorry, you are not allowed to access this page’ is closed to new replies.